Bad server response time


Google PSI shows the server response time at 1.3 - 1.9 seconds.

I have . file extensions all hard cached but cannot hard cache everything because the site constantly updates. I have ARGO enabled , CDN , deferring etc…

Is there anything I can do or perhaps this cannot be fixed because my origin server is slow ?

Not easily. You might be able to do a Cache Everything for the home page URL with an Edge Cache TTL of some low number of hours.

Yea , all of the .css/js etc is loaded from imagekit URLs … there is one JS relative to domain but hard-cached on cloudflare…the only request is from the server database I guess which cloudflare cannot help with. Hm! My server recently changed from PHP5 to PHP7 … before the change my server conn was about 0.8 … now it’s 1.3 so the PHP7 server is slower … would editing my PHP possibly improve the connection time?

Hello Cloudflare Community,

Since we changed our server from PHP5 to PHP7 we are seeing the server response time go from about 1 second to 2 seconds :slight_smile:

DESKTOP >> Reduce initial server response time - 2.04 s

My server people say that I should login to Cloudflare and change settings to reduce the server response time.

Is there anything in Cloudflare that will do this?

I have ARGO enabled , hard cache of . file extensions , network HTTPS3 etc all enabled.

I cannot hard cache everything because the site is very dynamic.

I have a feeling that the server response is SOLELY down to the server’s slow processing of database requests?

Any help would be great!

Site is :

I think your feeling is correct, i’ve just had a visit of your site and ceause everything is dynamic, it goes through your origin

still insecure.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.