Bad gateway?

Well if its conflicting with whatever CF holds over this, then yeah I think I need to know. Which one has more power, dns or htacess - which one is going to overwrite the other. Therefore there is a gateway problem?

But the issue is not Cloudflare, the error comes straight from your server. Nothing of Cloudflare is involved at that point.

Once I activate CF there is a bad gateway. It means that CF setting conflict with server settings somehow. So one of them must be removed, and whenever I remove CF server operates fully. So if I need to remove htacess or correct it, I can and CF should work fine.

Cloudflare settings cant influence your server as they work exclusively within Cloudflare’s infrastructure and that is unrelated to whatever your server returns.

If your server returns an error you need to clarify this with your host. The error comes from your server, thats all I can say. Why, is something your host will need to tell you.

CF is not picking up the correct server IP. It keeps requesting old server IP.

Well, first of all you seem to be ignoring the fact that your server does not return anything either and that could not be more unrelated to Cloudflare.

Secondly, what are you basing this claim on? And if it is true, you will simply need to fix the address in your control panel. There were some intermittent propagation issues yesterday, but they have been fixed.

2 posts were split to a new topic: Nameservers point away from Cloudflare when domain is registered here

I transferred that domain over here and I’m waiting to see if it makes any difference with this bad gateway. I have tried everything!! My server runs FINE without CF so there is clearly something with the linkage - I don’t want to be annoying but the server works fine without CF so it’s not that fault. CF for my domains won’t work. What else is not cooping with CF? Litespeed? Cache plugins? anything else?

Transferring it shouldn’t make any difference to this issue, but make sure that in Cloudflare, your A record points to the IP ending in 59 and not the one ending in 60 as 59 is what your site is currently working on.

I have had these setting all along, and still bad gateways whenever CF is activated. Am I missing something?

That looks OK to me, unrelated to the issue, I would not expect your email to work with those settings, but the settings for the website look OK.

Right, precisely what has been filling up this thread. You have now witnessed it work at without CF before I now activated it back.

NOW I just changed this other domain below to CF NS, and this is what it looks like:

And just to put it out there. My host (with ending .59) moved from .60 just recently. I changed the 60 to 59 but is there anything other than that that I need to fix/edit/etc?

There shouldn’t be, I will take a proper look at this issue tomorrow if no one else does beforehand.

Yes please!! :frowning: Let me know if you need logins/other to get the full picture. now went from plain html bad gateway to the CF bad gateway display. (Mozilla) but Chrome says it was redirected too many times as an error? hmm

We are going in circles here. As mentioned numerous times your server is throwing that error. You keep ignoring that fact.

Hang on, we were talking all the time about the 60 host. That is the active host when this entire story started. If that has changed now and was not applied to Cloudflare, it would not be a surprise that it doesnt work.

1 Like

Ok so how do you now explain me transferring my domain to CF and it works on my website now?

I am not sure what you mean by that question. You did transfer your domain to Cloudflare but that is completely unrelated to hosting anyhow. Furthermore you have the nameserver issue mentioned in the other thread.

The NS needed to be changed to CF just like I did from domain reg. Now all of sudden it all works fine.