Bad Gateway 502 Error after purchasing Dedicated SSL

dedcerts

#21

It behaves like these settings are turned on and redirecting the http request to https, but my browser doesn’t seem to like that approach and flags the mixed content warning because of the initial call.

Is there some option in the Coming Soon plugin to forcibly set the image to https?


#22

thats if i used it right. just copied what you did lol.


#23

This is also a good time to pursue the Third Party SSL certificate. Here’s the HostGator page to get you started:

https://support.hostgator.com/articles/ssl-certificates/acquire-ssl/how-do-i-use-the-third-party-ssl-certificate-i-purchased

Once you take care of that on the HostGator end, take a breath and have a coffee break before moving on to the final settings changes on Cloudflare and Wordpress.


#24

doesn’t look like it.

ok it seems like i can’t create any answers anymore as i am a new user and have reached my daily limit. have to wait 19 hours to be able to answer again. lol.

no also nothing in content and design. so should i change something in the media library?


#25

Nothing under the Content or Design tab? I’m not terribly surprised, as it looks like it’s tying directly into the WordPress media library.


#26

No, it looks like you’re stuck in that regard, but I don’t know why. It could have something to do with how the Coming Soon page calls images. I think the Javascript is making the call, and Cloudflare can’t correct that as it’s run from the visitor’s browser.

The good news is that a regular WordPress site shouldn’t have this problem, so once you turn off Coming Soon, this should go away.

More good news is that once you get Third Party SSL set up, all this headache goes away.

I’ve messaged you on Facebook if you need more help.


#28

You don’t need to have an SSL cert on your server (your origin server).

CF’s SSL Full Strict setting relates to the connection between your origin server and CF.

You can use CF to present an SSL connection to the world.

I think the mixed content warning you are getting on coming soon page is because that coming soon page isn’t coming from your account, but rather from the (nobody) Apache user that servers up the coming soon page for all new accounts.


#29

Hello!! I am experiencing the same problem! How did you solve it? Thanks


#30

Hi

I have bad Gateway 502 error Please Follow up this problem

My script is Data Life Engine V 11.1

/engine/skins/codemirror/css/default.css Failed to load resource: the server responded with a status of 522 (Origin Connection Time-out)
/engine/ajax/templates.php Failed to load resource: the server responded with a status of 502 (Bad Gateway)
default.css Failed to load resource: the server responded with a status of 522 (Origin Connection Time-out)

Please send to me Response


#31

Quite often, it’s because the SSL setting for your site doesn’t match the SSL configuration on your server.

In Cloudflare’s Crypto tab, what is your SSL setting? It could be Off, Flexible, Full, or Full (Strict).

Do you have an SSL certificate installed on your server? Is it self-signed, or issued by a regular Certificate Authority?


#32

No

I don’t have SSL

what I do now?


#33

See if you can find out why your server isn’t letting Cloudflare connect.



#34

Whats Your Host? Because same issue emerge at https://www.techmedias.xyz when I tried activate https… this issue can make someone lost huge traffic


#35

ThankYou

Sever fix the problem they are said to me: we are changing security setting

Thank You for your help


#36

Hi

I have a Problem

I buy SSL for my domain

But it isn’t working

For Exam :

This is Working

http://aembearings.ir/main/162-گریس-های-مخصوص.html

This isn’t Working (SSL is Enable )

https://aembearings.ir/main/162-گریس-های-مخصوص.html

Host support say: This Problem for CloudFlare

What do I do?

ThankYou


#37

Dedicated Certificates are not available for .ir domains (and some others).


#38

So i dont using Cloud Flare for SSL?


#39

Yes I have SSL in my server


#40

I expect that Cloudflare’s free SSL (Universal SSL) will work. No real need for a Dedicated SSL certificate.


#41

Free SSL dont working for IR domain

& I buy SSL my domain but I cannt set in CloudFlare