Cloudfare Verifying Connection Loop Glitch

Hello, I use Google Chrome and I can access normally when I’m not in-game. Now, whenever I join a game, activate the Steam Overlay and open my browser, which is also Chrome, it won’t let me navigate on

It goes to the “verifying connection - verifying you are human” page and after I check the box and complete the verification step, it simply refreshes and gets stuck at the same page.

Now, I must add this has happened to me once before, and just like the glitch appeared, it also disappeared and things went back to normal, with no need of me doing anything.

Can anybody help me out please? Much appreciated, yours truly, JB.

Hi there,

You have a rule called “Captcha all remaining requests” that shows an interactive challenge that steam is apparently not capable of going trough, even though you’re human. (I’m assuming you’re human and not a robot trying to bring us all down :sweat_smile: )
This failure might be either because of the browser not having cookies enabled, or maybe because it blocks JS. I actually don’t know.

You might want to try clearing cache and cookies, and see if that helps, if it doesn’t, consider changing this rule or create a more specific one for steam users.

I would go to Security → Events, then set the filter to 30minutes/Live and trigger the WAF by growing from Steam, then I’d locate the event and see if there are any particular information about the request detail that I can use to create a specific rule.
For instance HTTP version+User agent.
I would then create a rule specific for steam users and try other different types of challenges like JS Challenge or Managed to see if it’s easier to complete any of those from steam.

Take care.

1 Like

Hello there “mcorreia”, thank you for the reply, I sincerely and truly appreciate it. I’ve already tried clearing the cache and cookies, somebody else told me to restart my router/modem, also looked up for solutions on the internet, but nothing worked.

One thing that I forgot to tell is that this has happened to me before, last year, and I couldn’t resolve the issue back then, but then it suddenly disappeared, got “fixed” somehow. No clue of what happened.

This second time this is happening to me started right after the latest Steam Update with the new layout.

The other steps to try and solve the problem that you explained to me on your reply, I have to admit that I didn’t understand them very well. I’m sorry, but I’m a layman on the matter here.

Well, anyways, I’ll see what I can do, and if nothing works out, I can always wait again to be suddenly “fixed” somehow, I guess.

Thank you again for your reply, yours truly, JB.

PS: “mcorreia” mind if I ask where are you from?

1 Like

This might be the issue, something got changed in their browser that makes impossible to solve the interactive challenge - you can try changing the type of challenge though, you might get trough by changing it to managed and your website will still be protected.

I’m a world citizen :laughing:
Currently somewhere sunny in Europe

1 Like

How can I change the challenge? And the website you mean is the one I’ve been trying to access, right?

I asked because I thought you were a fellow countryman.

1 Like

Hi there,

Fastest way would be to edit the WAF rule named “Captcha all remaining requests” and change the “action”:

I suggest trying the managed challenge first.

Take care.

Please forgive me, but like I said, I’m a complete layman on the subject here: how do I do that?

Hi there,

Go to SecurityWAFCustom rules, find a rule called “Captcha all remaining requests” and press Edit, then scroll down to the bottom and change the action to “Managed Challenge”.

Take care.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.