Azure IdP - that account does not have access

Hello, I’m setting up Azure AD IdP for my domain. After completing Auth flow for Azure AD, Cloudflare reports error ‘That account does not have access’. Is there any additional config that might be needed? Any tips on the approach I can take to resolve this, thanks much.

Has the user been granted permission to the application in Azure?

@Cyb3r-Jak3 yes, I even tried Github as IdP, same issue there as well : That account does not exist.

Did you test in Azure that the connections is working?

HI @Cyb3r-Jak3 yes the connection is working. That’s why I verified both with Azure and GitHub IdP, in both cases Cloudflare is reporting the same error, I understand some users have reported it in the past and it was fixed by Cloudflare, but then I’m still getting it.

Any further clues on how to proceed?

I don’t but maybe another @MVP can provide further debugging.

1 Like

Can you show us your application policy i.e. how you allow your users to access your application?

1 Like