AWS domain and CLoudFlare DNS: Pending Nameserver Updates

Hello,

I have a domain registered with AWS Route 53 and I want to use Cloudflare services…

below what I have done:

  • added website to Cloudflare
  • Verified the website
  • noted the Cloudflare DNS values
  • open AWS Route 53 and modified the existing NS records to the one provided by Cloudflare

—> one day later (18 hours) I still get the Pending Nameserver Updates in Cloudflare

What am I doing wrong? any way to see why this is not working? have I been impatient or there is something wrong? (maybe syntax?)

Thank you all

Does the nameserver you’ve added ends with period?

the previous aws nameserver had that… so I thought it was just a naming convention…
Cloudflare nameservers do not have the “period” at the end"… should I remove it?

Yes. The Cloudflare nameserver does not have it. So, it that won’t work. Try removing.

I have tried… lets see…

BTW, I have noticed that the old NS records are fetched in Cloudflare without the “period” at the end, while in AWS, under the configuration, they are this the “period” at the end…

and am not sure that the period needs to be removed form aws… in any case I have tried… how long will it take to refresh? (it says 24 hours, but I assume that that is the max time… )

Greetings,

Thank you for asking.

From the screenshot you’ve shared with us, that’s a DNS zone at AWS hosting, however I am afraid you might be adding or modifying the NS type of DNS records instead of the domain nameservers at your domain registrar, which indeed is not the same as it might sound at first sight :thinking:

Otherwise, you might want to wait a bit longer due to the long TTL value being set :thinking:

Can you double-check and determine who is your domain registrar and where did you registered it?; there you change the domain nameservers.

By the domain name from the screenshot, your domain registrar is https://registrar.amazon.com.

Helpful articles on that topic:

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.