AutoSSL Failure

Hi I am getting an error message trying to set up SSL on an addon domain on my BlueHost account. I was successfully able to get the primary domain to work. I am moving two Wordpress websites from Hostgator to BlueHost that use the Cloudflare CDN. For the primary domain I just migrated using UpdraftPlus then changed all the DNS zone records to the new ones then used AutoSSL on the BlueHost end and everything was happy. I have done the same with the addon domain but get errors when using AutoSSL. Can somebody help me out? I am very technical but this unfortunately is not my specialty. I am under the assumption DNS records only take 5 minutes to propagate.

The website loads fine for me & the DNS records look correct.

That error which you posted seems to be more of an issue with your server not serving the acme-challenge.

Can I ask why you’re trying to use this AutoSSL? Cloudflare automatically generates a certificate for you and you only need one on your origin so that the traffic between Cloudflare & your origin is encrypted.

For that purpose, you can use an Origin CA certificate which can be installed on your origin & lasts up to 15 years.

Re AutoSSL I’m just trying to get SSL set up. That is one of the two options on the BlueHost side and it worked for my main website on the same account… no idea why it won’t work for the addon domain. I’ll look at that link you gave me. Thanks.

Is there any way to do this without messing around with all those technical instructions? I just want to click a button…

I assume the only other way to do things is to get BlueHost to set up an SSL certificate on their end right? If I can’t get that to work does that mean my only option is to use the approach you mentioned and linked to?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.