Autoplay on Cloudflare Stream Only Works When Loggedin as Admin?

Having some issues getting the autoplay to work on a Cloudflare stream video.

When logged in as a Wordpress admin, I get it to work, when I am not logged in, I fail to get the autoplay to start? I am using Chrome browser each time, one that is logged into the Wordpress admin and one without. I also get it to autoplay on Safari when not logged in.

Autoplay is not always permitted behaviour by the browser. How this is handled, will vary from browser to browser and in Chrome, even from site to site and day to day, as it learns your preferences based on history.

Have a look here for an overview of how Chrome handles autoplay.

…we’re announcing a new policy on Chrome desktop to block unwanted autoplays…

I suspect it’s working when logged in, because Chrome has learned your behaviour. Are you testing the non-admin access using a Private window? If so, perhaps that established pattern of behaviour is disregarded there :thinking: