Automatice redirection to https from http is not happening

I have not been able to configure automatic https redirection.

I want my website sitting at http://quickswap.exchange to automatically redirect to https://quickswap.exchange

But, it’s not happening right now. Both http and https version works parallel.

FYI, quickswap.exchange is hosted on ipfs and served through Cloudflare ipfs.

Always Use HTTPS


This setting will redirect visitors from the HTTP version of your site to the secure HTTPS version. This means that all visitors connections will be secured.

Automatic HTTPS Rewrites


This setting can help fixed mixed content issues. Although it may not be able to fix all these issues, I recommend turning it on if you experience mixed content issues.

Please read this for More Details

I have already all those settings

Can you Share a Screenshot of that Setting ?

Can you Share a Screenshot of that Setting ? Have you also enabled Automatic HTTPS Rewrite

Here are the screenshots

Only the Main Domain is loading in HTTP

The Sub Domain
QuickSwap Info is loading fine In HTTPS

Once try adding a Page Rule & check like this

Still does not redirect.

image

@sameep it looks like a bug to me. Have you contacted Cloudflare Support?

It is loading fine for me

Force http:// on the URL itself. And don’t use the latest version of Chrome as Chrome will always attempt to connect via HTTPS no matter which protocol you are putting in your URL. I was using Microsoft Edge to test it.

1 Like

Oh , Ok i think he need to contact the support

That’s an IPFS host/website it appears… it doesn’t support that feature today.

3 Likes

@thibault1 can usually enable “Always Use HTTPS” for IPFS sites.

3 Likes

Hi @sameep,

I have enabled ALways use HTTPS for quickswap.exchange.
We currently have the IPFS gateway in private beta. Looking at your configuration, we’d be glad to have discussion to get you access. Just fill the following form.

2 Likes

Thanks a lot. Can you also enable “Always use HTTPS” for our sub-domains?

info.quickswap.exchange
alpha.quickswap.exchange
dev.quickswap.exchange
beta.quickswap.exchange

And how to enable it for all our future subdomains as well?

1 Like

I have also filled the form

1 Like

I have done these on the subdomains you mentioned.

Thank you

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.