Automatic WARP client install - Registration Missing

I have read through the WARP client documentation several times to try and make sure that I am not missing anything. I cannot seem to get the WARP client to work when installed via automated methods. Whenever I do, the client pops up with “Registration Missing” and doesn’t allow the connection to start.

I’ve created a Service Auth secret. I’ve added that Service Auth as an Include rule on my device registration settings. There are no other Require or Exclude rules preventing access. The only other rule is an Include that specifies a certain email domain.

When I run the installer, I include the ORGANIZATION=“” value, along with auth_client_id=“” and auth_client_secret=“”

My full install string (with the secret and organization name sanitized) is below:

msiexec /i Cloudflare_WARP_Release-x64.msi /qn ORGANIZATION=“myorgname” auth_client_id=“xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx.access” auth_client_secret=“xxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxxx”

Any advice on how to get this working is appreciated.

1 Like

I’m having this exact same issue as well – and also having trouble getting the iOS mobile app registered too. Cloudflare’s incomplete instructions are making this unnecessarily very difficult compared to Cisco Umbrella and DNSFilter.

1 Like

I ran into the same issue and this worked for me

Create a ‘Device enrollment permissions’ policy with a rule action to ‘Service Auth’ instead of ‘Allow’ for your token

More info here

C:\ProgramData\Cloudflare\cfwarp_service_log.txt gives the error
warp::teams_auth: Response for Access JWT did not include 'token' query parameter.


This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.