Automatic Platform Optimization

Activated APO on my WordPress blog.

Are the below headers correct:
for text/html
x-via:speedwp/origin,no-cache

for text/css
x-via: speedwp/origin,bypass

does not seem to be loading google fonts vis APO.

Hi @kunal.desai1.

Thank for trying out APO. Please make sure then you test APO you don’t send any of the following request headers, they will instruct APO to bypass caching:

  • “Cache-Control: no-cache”
  • “Cache-Control: private”
  • “Pragma:no-cache”
  • “Vary: *”

By default Chrome will add them when DevTools are open, you can disable it in the settings (uncheck Disable Cache):
Screen Shot 2020-10-03 at 8.29.58 PM

If you have further question I wrote a detailed post about APO activation.

1 Like

With cache level as standard, I get speedwp/cache header but only for html not for static assets.

With cache level as everything, no x-via header is present.

Correct, when APO is enabled the APO worker script handles html content and google fonts proxying, static assets should be cached by default.

1 Like

Till yesterday, I was getting x-via: speedwp/origin, bypass for static assets.

Now I am getting, x-via: speedwp/origin, nohtml.

@yevgen Same here. First I visited the site homepage and then clicked on the second blog post. Here’re the details:

URL: https://insidebedroom.com/zinus-mattress-review/

cf-cache-status: DYNAMIC
cf-edge-cache: cache,platform=wordpress
server: cloudflare
x-cache: uncached
x-via: speedwp/origin,nohtml

Please check the screenshot:

Please help me.

1 Like

Switch off Custom Page Rules.

1 Like

Thanks @kunal.desai1 for replying.

I have custom page rules for admin pages and preview pages only. See the screenshot:

Will it create any issues? Please let me know.

1 Like

Kindly switch off the wp-admin as it is handled perfectly by APO.

1 Like

Turned off all the Page Rules still it’s not working:

Site URL: https://insidebedroom.com/

1 Like

Hope you had purged the cache after switchiching off page rules.

Plus saw a header, x-cache: cached. Disable this at as it interferes with APO.

Even I have switched off caching plugins at host.

1 Like

We rolled out the change that will serve cf-edge-cache: HIT when the page is returned from KV storage, because of Cloudflare Cache eviction rules any page could be removed from Cache if not regularly requested in specific data center. I hope you will see cf-edge-cache: HIT more often now on your site.

2 Likes

@yevgen Thanks for replying.

So I can set the page rule that I shared above, right?

1 Like

Hello @kunal.desai1,

I turned off the varnish cache from the server, now you will not see x-cache: cached.

Still, APO is not working :frowning:

APO is working on your site.

Saw headers x-via: speedwp/cache for text/html and x-via: speedwp/origin, nohtml for static assets.

3 Likes

Thank you Kunal for letting me know. Have a nice day.

2 Likes

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.