Automatic Platform Optimization for WordPress - Not detecting the plugin

Hello, I have installed the CloudFlare plugin to my WordPress website and also purchased the Automatic Platform Optimization for WordPress but when I click to check for the plugin so activate it, it says that the plugin is not found yet i have it installed.

Kindly help me

Means the plugin is already activated in WordPress but not detected?

Did you already login to the Cloudflare plugin using API keys?

hello, yes. I did every however, i used the wordpress template API when loging in because the global API was also not working as in helping me activate it

Please activate APO from the Cloudflare for WordPress plugin, also you need to purge any server caching you have in place if any.

I’ve had a lot of trouble also gettingit activated and tried the following:

  • disable (wordfence) firewall;
  • disable firewall on server.
    Didn’t help.

Went trough the error_log on the server (most of the time you can find it in the control panel for the site) and found it gave the following error

AH01623: client method denied by server configuration: 'PATCH'

This is the place to look for problems, your error logs. You might have the same problem as above or another one.

So I updated the server allowing it. I’m using DirectAdmin, they have instructions how to do that on their supportsite. If you cannot make changes to your server or VPS-configuration, ask your webhost to do so.

After that log in to CF panel, click on “Speed” icon and at the overview page scroll down. Under
“Automatic Platform Optimization” click on the button to enable it. You can now go to Optimization tab, and Automatic Platform Optimization for WordPress should be on or can be turned on.

In my case, CF can’t see I’m running Wordpress and says “This optimization is only available for websites using WordPress. We did not detect WordPress running” but that’s fine since I have configured my website in such a way you can’t see that :slight_smile:

After that I could turn the plugin on in my Wordpress dashboard. Before I also could but it wouldn’t hold this setting. Now it does.

So hope this helps a little? Most important: make sure nothing blocks it (firewalls). If that isn’t the issue, check the logfiles and see if CF is blocked for some reason. Like in my case.

---- update: What I do notice that, despite the above, Cloudflare panel still doesn’t recognize I use Wordpress. Hoewever, after turning it on from the Wordpress dashboard and turning it on in CF’s panel it does work. I tested it using

curl --request GET -I -H "Accept: text/html"

and it shows

CF-Cache-Status: HIT

What I noticed is that if you ‘enable’ it and return to the page it is back to the original setting. It seems like it works (in the Wordpress dasboard it’s active and when I test using cURL it shows a hit) but still… shouldn’t this be a green “V”? Or is this as it’s supposed to be after enabling?

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.