Automatic Platform Optimization (APO) Doesn't work on my server. Switched OFF after turning on

Hi there,

I’m encountering an issue with Cloudflare’s Automatic Platform Optimization (APO) for my WordPress websites and haven’t been able to find a solution in the forum or documentation. I’m hoping someone here can assist. Normally I can install it quite easily, but the problem is something server related, but I don’t know what…

For both of my domains, including, I’ve enabled APO through the Cloudflare plugin on WordPress. However, after a page refresh, the APO setting toggles back to OFF by itself. I’ve confirmed that no other caching plugins are active that might interfere with APO.

Here are the steps I’ve taken to troubleshoot without success:

  • Cleared all caches on WordPress and Cloudflare.
  • Deactivated and removed the Cloudflare plugin.
  • Generated a new API key and reconfigured the plugin.

Despite these efforts, the issue persists. When I access the Cloudflare plugin, I’m greeted with an “Internal Server Error” message, but no further details are provided.

CF-Cache-Status: DYNAMIC

I’m running WordPress version 6.4.2 with the Cloudflare plugin at version 4.12.3

Has anyone experienced a similar issue or can offer insights into what might be going wrong?
Errors in console:


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.