Automatic HTTPS Rewrites are not working properly

Currently, I have the “Automatic HTTPS Rewrites” option on and my website is coronaspreadsim.me . When I type this and click enter, I go to http://coronaspreadsim.me rather than the https:// version. The https version definitely works but I don’t know what the problem is.

Thank you in advance.

3 posts were merged into an existing topic: HTTPS not working - The “Always use HTTPS” options doesn’t work