Autodiscover not working

My customer (4 users) stopped receiving emails 2 weeks ago when using Outlook, though WebMail with RackSpace ISP continued working. It appears to be an autodiscover issue, as that fails. DNS records have autodiscover as a CNAME with Proxy link to autodiscover+emailsrvr+com (+ = .) (RackSpace), and this hasn’t changed.

If I try and use the address autodiscover+oxleyconservation+co+uk (+ = .) in a web browser, Cloudflare redirects to a web page indicating a 521 error, web server down. If I use the proxy address, autodiscover+emailsrvr+com (+ = .) instead, then I’m prompted for a username and password, i.e. there is something there at the other end. Not sure where to go from here as RackSpace don’t believe they have a problem. Why do I get a 521 from Cloudflare

Greetings,

Thank you for asking.

I am sorry to hear you are experiencing an issue with receiving and/or sending e-mails while using Coudflare for your domain name.

Is the CNAME proxied :orange:?

Kindly, try switching e-mail related DNS records like A autoconfig, A autodiscover, A mail, A webmail to :grey: (DNS-only).
Make sure your MX record for your domain is pointed to an unproxied (:grey: cloud) mail.domain.com.
Double-check your e-mail client MS Outlook and make sure you’re using mail.domain.com for POP3/IMAP/SMTP.

Usually, the MX record should point to a hostname such as mail , and the A (or CNAME ) type record for that hostname should be set to :grey: (DNS Only).

Furthermore, if you recently moved your domain to your Cloudflare account, I could try to troubleshoot at first sight without knowing anything other as it could be related to either:

  1. Wrongly setup e-mail related DNS records at the DNS tab of Cloudflare dashboard for your domain name
  2. Possibly missing some TXT /CNAME records (for SPF , DKIM, DMARC if so?)
  3. You are using a hostname like yourdomain.com which is :orange: (proxied) rather than the unproxied :grey: (DNS-only) like mail.yourdomain.com (possible this one not existing or is :orange: instead of being :grey:) at the DNS tab of Cloudflare dashboard, in your e-mail client for sending/receiving server (MS Outlook, Mozilla Thunderbird, etc.)

May I suggest checking below article if your e-mail records (usually the A mail and the MX record) are configured properly while you are using Cloudflare for your domain name:

Regarding Cloudflare 521 error, may I suggest you to try looking into below articles to troubleshoot the issue:

Furthermore, before moving to Cloudflare, was your Website working over HTTPS connection?
May I ask what SSL option have you got selected under the SSL/TLS tab at Cloudflare dashboard for your domain ( Flexible, Full, Full Strict … )?

Here is a way to re-check if you correctly setup the SSL for your domain with Cloudflare:

In case you do not have an SSL certificate, you can use Cloudflare SSL, if so, kindly make sure you follow the instructions as follows on the below article to setup an SSL certificate using Cloudflare Origin CA Certificate:

Last but not least, kindly have a look here for more information regarding correct SSL settings at the SSL/TLS tab on Cloudflare dashboard:

Furthermore, do not skip below step and kindly re-check if Cloudflare is allowed to connect to your origin host to as follows in the below article:

Nevertheless, Cloudflare IP addresses list can be found here:

Hi, thanks for the suggestions. I switched the Autodiscover CNAME record from Proxy to UnProxied and now everything is working again. I guess RackSpace objected to a Cloudflare IP address that had found its way on to a block list?

thank you for your help.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.