Auto redirect http to https

Hello Team,

My website switchswap.finance is hosted on IPFS but it isn’ auto-redirected to https, both http and https work separately, do you know how to fix it? I selected “Always Use HTTPS” and “Automatic HTTPS Rewrites” already but it isn’t resolved.

Thank you.

Hi @switchswapdapp,

I believe Cloudflare have to manually force HTTPS for IPFS sites, can you email [email protected] from the email on your account asking them to force HTTPS on your domain.

You’ll then receive a ticket number, please post that here and I’ll escalate it.

2 Likes

Hi @domjh,

Thanks for your info, I sent an email to cloudflare support, the ticket number is #2227189

Thanks, I’ve escalated this topic and your ticket.

2 Likes

Hi @switchswapdapp ,

I have enabled Always use HTTPS on switchswap.finance. Feel free to get back to us if you encounter any issues.

4 Likes

Thanks @domjh and @thibault1, you saved my life :star_struck: I was stuck there for a week

2 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Hello Team,

My website switchswap.io is hosted on IPFS but it isn’ auto-redirected to https, both http and https work separately. I selected “Always Use HTTPS” and “Automatic HTTPS Rewrites” already but it isn’t resolved. I contacted the support and get ticket number #2251854. Could you please have a look?

Thank you for your help.

Maybe create a page rule to do this follow the steps below

  1. Log on to your cloudflare account
  2. Click the domain switchswap.io
  3. Click on “Page rules”
  4. Click “Create page rule”
  5. On the dropdown, scroll and click “Forwarding URL”
  6. Set the Forwarding URL to https://www.switchswap.io
    If you want to redirect to the http version then set the forwarding URL to http://www.switchswap.io (and follow all other steps the exact same, in order).
1 Like

Thanks for your help.


I created a rule as above but it doesn’t work.

I can reproduce this issue:

Navigating to http://level.gg fails to forward to the SSL domain. I should note that “Always Use HTTPS” under “Edge Certificates” is on, as recommended by documentation.

1 Like

Hi @domjh @thibault1
Could you have a look at my ticket? Thanks in advance.

Hi again @switchswapdapp,

I’ve escalated this again with your second domain.

Thanks @domjh
Do you know whether there is a manual way that I can do it myself? I hosted my websites usually on IPFS but don’t know how to activate the auto-transfer on Cloudflare.

As far as I am aware, you can’t do it yourself. IPFS is an unusual case, kind of like an external service that uses Cloudflare. Essentially it’s The orange to orange problem where your Cloudflare settings won’t take effect.

I was hoping that future tickets about this wouldn’t be deflected to the community, as we definitely can’t help with it here. I’ll check up on that.

1 Like

This is because you do not have Cloudflare proxying (:orange:) turned on for your level.gg dns record, so requests are going directly to your origin server.

I recommend opening your own thread if you’re still seeing the same issue after turning on proxying.

1 Like

Hi @ethan.n.ho ,

level.gg does not seem to have a CNAME to cloudflare-ipfs.com, nor has DNSLink setup. I don’t think it is configured to use Cloudflare IPFS gateway.

@arunesh90 comment would be a first place to look at. While level.gg is using Cloudflare DNS (its nameservers are elma.ns.cloudflare.com and justin.ns.cloudflare.com), its traffic is not proxied through Cloudflare :orange:. You should look at Step 3: Enabling the 'Orange Cloud' to configure your zone to be oragn clouded.

1 Like

@switchswapdapp this should be resolved now, thanks to @thibault1, however they also provided this info so I’d recommend checking your setup.

It is not using managed CNAME, but is directly pointing to the IP of cloudflare-ipfs.com.

1 Like

Thanks @domjh and @thibault1
I deleted the rules that transfer HTTP to HTTPS and it works smoothly now.

1 Like