Auto HTTPS: MySite.com vs. www.MySite.com

I set a page rule for http://www.MySite.com. It appears to be working correcting so that if I go to www.MySite.com or http://www.MySite.com I get directed to https://MySite.com.

However, if I go to MySite.com I get directed to http://MySite/cgi-sys/defaultwebpage.cgi and I am told that I may have reached the page due to IP address change, server misconfiguration, or site may have moved to a different server.

In response, I set a second page rule for MySite.com and auto https. But, I am getting same result.

How to fix? People usually just type in MySite.com, I imagine.

Post your actual domain.

215Tax.com

Opening your naked domain on HTTP redirects me to its HTTPS version. That is what you want, right?

Yes. I checked on a different browser (phone) and it appears to be working right. Still not working in FireFox. Weird. Thanks for checking.

Probably a caching issue.

So, do I actually need both of those rules then? Or will just one suffice?

Can you post a screenshot of these rules?

You can delete both rules and simply set it domain-wide under the Crypto section.

Great thanks.

This is very frustrating.I deleted the rules + enabled the feature in the Crypto section. Now, whenever I go to naked version, www, http, or https, I get redirected to just "http//: But, site is working fine on my phone. Seems to be a browser issue, but I have zero clue why it’s now doing this.

I still get an HTTPS redirect, so it likely still is a caching issue. Clear your browser cache again.

Ack. That worked…thank you. New to this stuff.

This topic was automatically closed after 30 days. New replies are no longer allowed.