Authorization error with API TOKEN while reading DNS Zone

Hello all. I have created an API Token with read permission for ALL DNS zones. I´m trying to get the ID of one of the DNS records of one of the zones.
If I check token created I´m getting:

“messages”:[{“code”:10000,“message”:“This API Token is valid and active”,“type”:null}]

But if I now try to list the DNS records for a zone , I´m getting:

{“success”:false,“errors”:[{“code”:10000,“message”:“Authentication error”}]}

This is command I used:

curl -X GET “https://api.cloudflare.com/client/v4/zones/MYZONE/dns_records
-H “X-Auth-Email: [email protected]
-H “Authorization: Bearer TOKEN”
-H “Content-Type:application/json”

I read in posts like this one that people were having same issue and fix them replacing:

Authorization: Bearer BLAHBLAHKEY`
instead of X-Auth-Key

But in my case I already using it this way.

What else is need to be done ?

also here same case in other post with no replies:

thanks

Remove the X-Auth-Email header. That is for key auth rather than token.

yeah…I already tried that. Same result

why Is such a common error? what else could be happening here?

Also tried with postman and get forbidden 403 error

I have same error. Business plan.

Same.

I had the same issue that popped up late last week or earlier this week, can’t remember.

I was using X-auth and X-email in my headers and using a token (100% for sure). Then to document the process of creating a token I went and created another one, this time setting an expiration date, and it didn’t work. I deleted it and created another toekn just liek the first one and again, didn’t work. During all of these steps if i switched back to using my old token all was well.

Then I deleted my old token and all authentication attempts failed no matter what token i used. The fix was ditching X-auth nd using Authorization: Bearer MYTOKEN.

Hope that helps somebody.

While I agree it should be removed, my calls were happily working with that in the header while using Authorization: Bearer TOKEN