Authenticating email with DKIM

Hello there,

I am facing an issue with DKIM authentication which It takes only 48h to take effect in gmail but it has been more than a week but still not authenticated, I made sure of all the values entered my spf and dmarc are propagated, I hope anyone can help me fix this issue and thanks.

What is your domain and what records are you having problems with?

My domain is reachamine*com and I am having problem with DKIM record not updating or updating but not authenticating I don’t know exactly.

I can see the following DKIM record for your domain:
"v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAtWEm3JJjDS0XOHqgWNvlgDZpBvlcNysz5Suyc+2iGCUcIgwiKi9AdKW3pufn+6YVd8bT2IoJXdB9TAVQTE88TxTUmnvRf2awcGHPCHgH45coewJM9z+O7SITsuL0i68deggIdPXXoxaKhaJ/lH/H+L4wZg+OZa7/05yCsS7W4dBWnrtWldy9dwPvDV2lmCNDV" "hB46e0hEuQDHnAmlqFtC7oyz9WIUv9pgaio4FlDccCm4fLxlBCmeyMGPG31ns7vQtCg7TtT0SL1WbjZgqY0H7Y4Gsl3NXG//b0R6oXS2K7L0SlG1RdMqc5Ao8sYZyKGNV5WlVo9jMGwrPi275HQsQIDAQAB"

Is that what it’s supposed to be?

Something has added quotes and broken it in the middle. It should have the quote marks removed and all be on one line:

v=DKIM1; k=rsa; p=MIIBIjANBgkqhkiG9w0BAQEFAAOCAQ8AMIIBCgKCAQEAtWEm3JJjDS0XOHqgWNvlgDZpBvlcNysz5Suyc+2iGCUcIgwiKi9AdKW3pufn+6YVd8bT2IoJXdB9TAVQTE88TxTUmnvRf2awcGHPCHgH45coewJM9z+O7SITsuL0i68deggIdPXXoxaKhaJ/lH/H+L4wZg+OZa7/05yCsS7W4dBWnrtWldy9dwPvDV2lmCNDVhB46e0hEuQDHnAmlqFtC7oyz9WIUv9pgaio4FlDccCm4fLxlBCmeyMGPG31ns7vQtCg7TtT0SL1WbjZgqY0H7Y4Gsl3NXG//b0R6oXS2K7L0SlG1RdMqc5Ao8sYZyKGNV5WlVo9jMGwrPi275HQsQIDAQAB

That’s the normal split due to the 255 character limit per character-string. Dig doesn’t join these together automatically.

Yes that is what it is supposed to be but for some reason it is still not authenticated in Gmail after more than a week and they say it propagates only after 48h.

Can you show a screenshot of Google where we can see the record and the error?

1 Like


It doesn’t show any error it only shows that it didn’t propagate yet.

Have you tried generating a new record to see if that works?

While the info tells you it might take 48 hours… If it doesn’t work after 15 minutes, it probably never will.

1 Like

Yes I have tried regenerating the code many times.

Update: I Generated another code still nothing changed.

Your new DKIM record looks a bit too short. Can you show another screenshot of that?

You might want to see if you can get any support from Google. Everything seems to be as it should from what I can see.

1 Like

I try to get some support from them but they just blast their AI assistant in my face, I try to go around it but I haven’t found anything yet do you have any suggestions?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.