Authenticated Pulls active on DNS that routes a worker causing 525 error when worker attempts to get data from 3rd party

I am using a route with my worker, on the domain I have set the route i have authenticated pulls on. Everything works great in the cloudflare editor testing window and when doing static requests. However…if the worker does a request to a remote server where it needs to get data coming back (ie oauth) it fails with a 525 error on the screen.

Given that an authenticated pull is related to the communication with a server…and workers supposedly being serverless and working on their own…i think this might be a bug. If I turn off authenticated pulls and run it in a normal browser window it works. If I run the worker form worker.dev it works. If i run it with authenticated pulls on in the cloudflare testing environment it works.

It only does a 525 when running in a standard browser window and making a request to a third party with data with authenticated pulls on.

Turns out I really need that scenario to work…any ideas for a work around? Or if this is indeed a bug…cloudflare can you fix!? Thanks!

Yo yo where’s everybody at! :smiley: Is nobody really using workers out there with routes?

Never came across this issue, but you could turn it off and setup Firewall Control on your server just for Cloudflare IPS access on http and https ports.

@adaptive I think the issue here is that that worker route should operating independently of the server, and not needing the ‘authenticated pulls’ settings interfering on its operations.

Firewall Control on your server just for Cloudflare IPS access on http and https ports.

True, but ideally having the authenticated pulls as a first layer of security would be nice to maintain instead of having to eliminate it from the equation.

My easier option is just to use a different domain not needing authenticated pulls, but i like the vanity of this domain and it if more people can confirm this bug the quicker it will be resolved probably.

I created a support ticket…but not seeming to get any response. Any coudflare workers developers lurking in here…?

@Judge any ideas…i feel like you are the cloudflare expert in this forum! tried changing the cname to a record with ip 192.0.2.1 but that didn’t work.