Aus-finance.com.au - logo not loading Mobile Only


#1

Hi,
The logo for https://aus-finance.com.au is not loading on my mobile devices. I’m on the free plan. I am also using WP Fastest Cache Plugin on my word press.


#2

This is a huge issue, conversions for today dropping off a cliff. If someone could assist, it would be much appreciated.


#3

Issue also happening on IE desktop:


#4

Working for me out of Melbourne (Chrome on W10, Chrome on Andorid 8.1). Being served from Sydney datacentre with logo from your WP uploads folder as expected.


#5

It’s fine on desktop pc as well on chrome, Firefox and edge.

The only issues so far have been on internet explorer desktop and safari iOS. The problem is that makes up 75% of our traffic.

See attached for what the site looks like with the unloaded logos on safari.

I’ve tried on another device using safari iOS and the logo didn’t load.

If I don’t get a fix for this tonight, I will be moving back to my old server and getting rid of cloudflare.


#6

Well you’re only using Wordpress and that works with Cloudflare just fine and your source looks normal. Your issue is the affected browsers are simply choosing not to render the image… this is more likely because although it’s a .png file I can see it’s being served as WebP (RIFF WEBPVP8X) so it could be either you have a file of a different format with the wrong .png extension uploaded (in which case the issue is more how does Chrome still work, not why are the other no working which would be correct) or one of the Cloudflare optimisations is serving up WebP images to clients which don’t support it.

If you defo have a .png uploaded and it works without Cloudflare proxying then you could try disabling Mirage or Polish and see if that serves the correct image (no idea as I’m not a pro customer). If it does and you’d like Polish and Mirage enabled then just turn it back on but set a ‘Page Rule’ to disable it for the path to that image so it isn’t converted.

But yes, problem looks like some browsers line .png files to be .png files, and not something else. But I could be wrong, I only looked a this for two mins.


#7

Thanks for helping Saul. Sorry, I thought I was chatting to someone from the cloudflare support team. Appreciate your assistance.


#8

No worries. Sure someone from the team will check in as well, just wanted to help where I could.

As I said, looks like the image has file extension png but just isn’t a png when i view it - I don’t know whether you’ve got a dodgy image uploaded to Wordpress (easy to check by just temporarily disabling Cloudflare and seeing if it still fails to load in which case it’s a bad file) or if the Cloudflare image optimisations are converting it to WebP (easy to check by disabling the mirage/polish features). It’ll be one or the other in all likelihood, hope you get it sorted.


#9

Cheers.

It isn’t a dodgy png file as it has been on the site for a few years (sadly). Only had cloudflare for a few days.

I’m not actually a business customer either so I don’t have polish or mirage enabled. However I am using a cache plugin on Wordpress which is compressing images which I think might be part of the problem. I don’t think it’s jiving with cloudflare. Thanks for your input.


#10

This is fixed now. I made an edit to the wp-config file to disable webP. Seems to have done the trick.