Attempting to redirect all www trafic to non-www trafic is not working

Hey there,

I’m trying to redirect all www (and http) traffic to a non-www url. I’ve set up rules, as pictured, but I am still able to access my landing page at the


www url. Any ideas?

Neither kindmind.com nor www.kindmind.com are proxied so requests aren’t going through Cloudflare to be redirected.
https://cf.sjr.org.uk/tools/check?8eb901f690c74827ad964c90e24375a7#dns

Secondly, this rule will redirect https://kindmind.com to https://kindmind.com and result in a circular redirect.

What you need to do…

  1. Enable “Always use HTTPS” here (this will do any http->https for you without a rule).
    https://dash.cloudflare.com/?to=/:account/:zone/ssl-tls/edge-certificates
  2. Remove “hostname equals kindmind.com” from the redirect rule, just leave www.kindmind.com
  3. Remove the CNAME in the DNS for www and replace with a proxied record of A 192.0.2.1 or AAAA 100::

This assumes your host is ok with the apex and IP addresses and does not need the CNAME to be visible. If it does, you’d be better off redirecting the other way (kindmind.comwww.kindmind.com).

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.