Astro Site Builds but No Content - Are Pages Logs Available?

Have an SSR / Astro 2.0 site with Cloudflare and Preact integrations.

Working fine on desktop in dev mode, but when published to pages I get a blank screen (white) with no content (page source just shows <!DOCTYPE html>. There are no errors or console errors.

The site has authentication that redirects user to a login page. Oddly, when I type in a ‘secure’ url I get redirected to the login page, but still no content.

The build log shows no errors (at least not any that I don’t already have on other working Astro sites). Likewise, I have NODE_VERSION (16) in the environment variables as with these other sites.

I believe the issue is related to my build, but what I am doing is no different than other Astro sites I published (except that it is Astro v2).

If you have a fix or tip great, but if not, what I was looking for are some kind of logs that might reveal an error. Do logs for CF Pages exist?

Thank you!

1 Like

Hey Jeff - I’m having the EXACT same issue.

I even tried a bare bones deploy with only the Cloudflare adapter, and still not working.

Would love to find the solution :slight_smile:

2 Likes

Same here, tried using the NODE_VERSION 17 variable (had 16) but still just a blank page with no body.

1 Like

@Chistopher & @girbaud - thanks for confirming the same…

For clarity, below are my dependency versions. Happy to provide more details if needed. Hopefully someone from Cloudflare will step up.

    "@astrojs/cloudflare": "^6.1.0",
    "@astrojs/preact": "^2.0.0",
    "@supabase/supabase-js": "^2.5.0",
    "astro": "^2.0.2",
    "preact": "^10.6.5"

@jeff76 @christopher did you guys eventually solve this? I’m running into this problem now

so I found the issue - “Cloudflare Workers do not support the credentials property in options (of the fetch function)” - https://github.com/cloudflare/workers-sdk/issues/2514

After removing credentials from all the fetch functions everything works =)

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.