Assistance With IPFS SetUp :)

Hello, CloudFlare community!

I have decided to venture into the decentralized webspace (partially).

I’ve purchased a domain name using the Dynadot website. Also, I’ve ‘pinned’ my site files to Pinata. Now, I seem unable to get my site to appear, and I"m sure it has something to do with my DNS settings. I followed the instructions seen in the image. But I must have done something wrong?

First off - I’m not sure whether to put this information into my Dynadot settings or my CloudFlare settings. I was so uncertain I tried to put them into both LOL. Which may be my problem now? Any assistance with this would be a big help as Google only continues to confuse me. :slight_smile:

@MoreHelp

I don’t use IPFS, so I skipped over this post.

Step 1 is pretty critical. It’s the authoritative location of your DNS records. Since you haven’t posted a domain name, I can’t check. Are you using Cloudflare name servers for your domain?

Thank you for the reply!

My mistake, I suppose posting my domain here would be helpful haha! (breekatt.io)

I got a hold of the registrar I purchased my domain at (Dynadot.com) and they told me I needed to have the nameservers set to cloudflare (which I already had set) - like this -
1

Then they insisted I get ahold of Cloudflare for the rest of the DNS settings. I already have them set like this, but am unsure what I am doing wrong…

These were all set like this last week (thursday-friday) and still no changes to my site. Also, this morning when I went to sign into my Cloudflare account, I was unable to sign in. Saying that I needed to have security codes, which I don’t believe I’ve ever received, so am dealing with that issue now too.

Any help would be HUGE lol thank you. :]

1 Like

It looks like you’ve followed the DNS settings correctly. And I see there’s something there. Beyond that, I don’t know what it takes to get your files working. Clicking on the one file that’s there does bring up a site.

I see your ticket with Support and have added myself to it to track. 2FA is enabled and you would have received the backup codes, it may be worth doing a search for those while you wait for Support to respond on the ticket. Sorry for the issues you’re hitting.

Ok, so the fact that it has an exclamation point next to CNAME makes no difference? Or the fact it says 'A few more steps are required to complete your setup" make no difference either? Perhaps I pinned something wrong to Pinata then, and will try to contact them as well. :confused:

Yes! I tried to email support about signing into my account. I have NO idea how to search for my codes. I don’t even remember receiving any but perhaps I did. I can confirm my account with 2FA using my mobile or email - but I do not have codes.

I think that’s a little “i” for Information that says the CNAME has been flattened in order to make it work.
The “Few more steps” would probably need the following to make it happy:

The MX record step is only if you have email at that domain, which I suspect you don’t, and can ignore that warning.

Think I fixed this!! When I was looking into my Pinata settings - I enabled 2FA with them. And while my phone had the authenticator app open (using my camera, which I would have had no idea how to open otherwise) - I was able to use a code to activate my Pinata 2FA - but ALSO saw that Cloudflare still had a code there. I tried that and it worked loll, so yay one issue solved. I can access my Cloudlfare account now again.

1 Like

This is confusing me just a bit (apologies because I confuse very easy LOL) - but is this saying that I need to add www. to my domain name? I was under the impression that it should only be domain.com (or in my case breekatt.io) without anything in front of it. Thought I read that somewhere when setting this up.

But now it’s recommended I add www. to the beginning of my domain? Where exactly?

Also, why not also add https:// then as well? (https://www.breekatt.io) -?

It’s only asking for a DNS entry because some people like to type ‘www’ in front of everything. With the DNS Entry combined with the Page Rule from the Tutorial, these people will be redirected to your proper site.

Ok, so I should add www. to my domain in this box here?

1

Also, again, just www.? or is it necessary to also add https://www. - as I would like my site (ideally) to appear with the SSL as well. :]

No, the tutorial is pretty specific. Add an “A” record for ‘www’.

Oof, ok I will try this and see what happens.

Also, is it ok to have my nameservers set to cloudflare on both my dynadot account AND my cloudflare account? Or should I only have cloudflare servers pointing to cloudlare on just one of the two? Right now both are set to cloudflare servers. I could delete them on cloudlfare or is it ok to leave it be?

Already the first step in the tutorial gives me an error - so I’m not sure if i should just skip that?

Error seen at bottom of image. It pops that up when I try to hit SAVE to complete the first step.

Ok, I set my page rule like so…

I only hope I did this correctly. Still very much baffled by it, to be honest.

I also skipped the last section because I don’t believe it applies to me…??

Note: If you have HSTS enabled
If your domain is on the HSTS Preload List, a requirement of this is that your domain redirects http://example.com to https://example.com before redirecting to www . This can be solved by setting the match URL to https://example.com/* and ensuring that Always Use HTTPS is enabled. This means the redirects will be:
http://example.com -> https://example.com -> https://www.example.com
rather than
http://example.com -> https://www.example.com
and therefore satisfy the requirements for your domain to be preloaded.

That’s all backwards. The tutorial told you to enter ‘www’ because you’re forwarding ‘www’ over to your site that does not have ‘www’.

Ahhh ok, thank you. Told you I confuse easy LOL

Is this correct then, instead?

Also, is it okay to have the same nameservers set under both accounts? (dynadot and cloudlfare) or would they mess each other up?

Thanks SO much!!

That page rule looks correct. But you still need the DNS record for ‘www’ as instructed by the tutorial.

You can ignore any name server changes at this point. It’s correctly set up with Cloudflare’s name servers in charge of your domain. Dynadot DNS will be ignored.