Assistance Required with Domain Redirection Issue after Transfer from GoDaddy

I recently transferred my domain, yammyhitz.com, from GoDaddy to Cloudflare. While the www version of my domain (http://www.yammyhitz.com/) is functioning correctly, accessing the domain without the ‘www’ (https://yammyhitz.com/) redirects to a GoDaddy page stating “This domain is registered, but may still be available.”

Could you please assist me in troubleshooting this issue? Ensuring both versions of my domain direct to my blog is crucial for my audience’s accessibility.

Are the DNS records for @ (yammyhitz.com) and www.yammyhitz.com set to point at the same thing in your Cloudflare DNS? (Show a screenshot of your DNS settings if you are not sure).

If yes, then likely you haven’t configured your Godaddy hosting to act for yammyhitz.com. You can either do that, or you can redirect yammyhitz.com to www.yammyhitz.com on Cloudflare.

To do the redirect, set it here…
https://dash.cloudflare.com/?to=/:account/:zone/rules/redirect-rules

Here are my DNS screenshot

Your apex A records point at AWS. Your www CNAME points at Google.

You could delete the 2 A records and add a new A record to point to 216.58.204.83 (which is ghs.google.com) but the IP could change so it may be safer to…

I would suggest you use your site only at www.yammyhitz.com, to do this:

  1. Delete the 2 A records
  2. Add a new A record and point to a dummy record of 192.0.2.1
  3. Go to redirect rules and add this rule… (if you want the redirect to pass the whole URL with the page when redirecting, we can adjust the rule).

Now the main page redirects perfectly as it should, but for example, according to the new rule I applied following the previous message from technical support, if you take for example the page https://www.yammyhitz.com/p/contact.html, without the www it will redirect to the main page instead of functioning at the address https://yammyhitz.com/p/contact.html. Is there any way to avoid this, to configure the rule so that the redirect is as dynamic as before?

Change the redirect from static to dynamic and set to concat("https://www.yammyhitz.com", http.request.uri.path)

1 Like

Check DNS settings on Cloud-flare for both www and non-www versions. Review active Page Rules in Cloud-flare. Review SSL/TLS settings on Cloud-flare. Clear Cloud-flare cache. Verify SSL settings on Cloud-flare. Seek assistance from Cloud-flare support for detailed investigation. Check server logs for insights into redirection problems. Allow time for DNS propagation. Test on different devices/browsers for local caching.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.