As a user I can't access a website

Even if I complete the captcha, it doesn’t redirect. It is stuck in a seemingly endless loop, and reloads the page.
Tried different browsers: Firefox 90.0.2 (64 bit) , Google Chrome 92.0.4515.131 (Official Build) (64-bit). Run multiple scans on my PC, no malwares detected. Privacy Pass add-on didn’t help neither.

It is a community owned site, no support there :frowning:

Is there an error number on the screen you’re presented? I am able to access the site ok, perhaps try in incognito mode.

Does the same in incognito mode too, both in Firefox and Chrome.
There is no error number :confused:

Incognito mode usually disables the usual ad blockers and other plugins that cause this looping behavior, but if your computer also has antivirus/etc. software, it can do the same thing. Have you tried from a different device?

2 Likes

It was my antivirus (bitdefender)
Thank you! :grin:

3 Likes

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.