Argotunnel Synology NAS redirect loop

I am having a redirect loop for my domain after setting up a CloudflareD tunnel from my Synology NAS (Docker container).

What I have tried to resolve?

  1. I have set the Cloudflare domain SSL/TLS to “Full (strict)” as suggested by Cloudflare as solution
  2. I have set the binding cookie policy to ‘Lax’ as suggested by some

Since I had previously setup the exact same subdomain with a tunnel successfully, only to delete the tunnel, I have tried the following to avoid interference due to previous setup.

  1. I have deleted and reinstalled Docker from my NAS completely
  2. I have deleted all cookies etc. related to the domain from my browser
  3. I have installed a second tunnel on a different sub-domain
  4. I have tried to access the tunnel via private browsing, cleanly installed browser, and other computer

I am running a hardware firewall with Zero Trust for my NAS and most traffic routed over commercial VPN, therefore:
7. I have set all Cloudflare Zero Trust domains as accessible by egress rules
8. I have assured that Cloudflare Zero trust traffic is not routed over the VPN (Cloudflare may block such traffic)
9. I have switched off the VPN to test that indeed I am still having redirects without using the commercial VPN

Using the Cloudflare Diagnostic Center, everything is good. Webpages running on the main domain and on subdomains work as they should.

So after all these, when trying to access my NAS via CloudflareD tunnel, still I have a redirect loop issue and I would appreciate if someone would be able to suggest other solutions than the ones tried above.

Thanks in advance.

Solution:

I found this is a Cloudflare bug related to the cloudflareaccess,com subdomain for your team, e.g. old,cloudflareaccess,com.

In order to make it work, I changed old,cloudflareaccess,com to new,cloudflareaccess,com. From the new subdomain my tunnel did not go into infinite loop and worked.

I changed back to old,cloudflareaccess,com and the tunnel kept working. Problem solved.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.