Argo tunnel with Kubernetes doesn´t work

argo

#1

Hi,

i am using Argo tunnel with Kubernetes. It worked last week fine, but now is a problem.

When i created an ingress definition, LB hostname (record in DNS) created automatically. Now LB hostname (record in DNS) doesn´t create

What is wrong? I didn´t make any changes…

My settings is the same like here https://developers.cloudflare.com/argo-tunnel/reference/kubernetes/ with change in helm install - in repo (-> tc/argo-ingress)

Thank for your help,

Jakub


#2

Hey @jakub.janecek

Could you provide us with the logs of your ingress pod?


#3

Could you use this ingress version in changing your ingress YAML configuration and see if it works better?

gcr.io/stackpoint-public/argot:ecf5bf3 This new version is gonna be released very soon and seems to solve the issue you’re facing.


#4

Hi stephane,

thank for your answer.

I tried change my ingress yaml conf but with error during create ingress… here is my code

apiVersion: extensions/v1beta1
kind: Ingress
metadata:
annotations:
gcr.io/stackpoint-public/argot:ecf5bf3
name: cards-ingress
namespace: default
spec:
rules:

  • host: mydomain.tld
    http:
    paths:
    • backend:
      serviceName: cards-argo-service
      servicePort: 80

and errors with validate:
kubectl create -f warp-controller-cards-new.yaml
error: error validating “warp-controller-cards-new.yaml”: error validating data: ValidationError(Ingress.metadata.annotations): invalid type for io.k8s.apimachinery.pkg.apis.meta.v1.ObjectMeta.annotations: got “string”, expected “map”; if you choose to ignore these errors, turn validation off with --validate=false

With flag --validate=false is errror too
kubectl create -f warp-controller-cards-new.yaml --validate=false
Error from server (BadRequest): error when creating “warp-controller-cards-new.yaml”: Ingress in version “v1beta1” cannot be handled as a Ingress: v1beta1.Ingress: ObjectMeta: v1.ObjectMeta: Annotations: ReadMapCB: expect { or n, parsing 79 …tations":"… at {“apiVersion”:“extensions/v1beta1”,“kind”:“Ingress”,“metadata”:{“annotations”:“gcr.io/stackpoint-public/argot:ecf5bf3",“name”:“cards-ingress”,“namespace”:“default”},“spec”:{“rules”:[{“host”:“mydomain.tld”,“http”:{“paths”:[{“backend”:{“serviceName”:“cards-argo-service”,"servicePort”:80}}]}}]}}


#5

Did you try a kubectl apply -f instead?


#6

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.