Argo Tunnel SSH Worked this morning, now blank screen

I set up two servers, respectively, this morning with a Tunnel and an Application for SSH access. I was able to connect to each, respectively, providing a user name, then the public key associated with an entry in the authorized_keys file, and finally the associated passphrase. Now, a couple hours later, all I get is a blank screen. It’s obviously not a config issue, they were working… I was logged into each server and good to go. Now the flippin thing doesn’t work. This isn’t ok!! It negates the entire reason for setting up a “reliable” secure connection. What the deal doc?

Thank you

Let me also confirm that 1) the tunnel(s) are up. 2) it’s not an issue with the browser. I originally connected w/ my Linux workstation default browser Chrome. I’ve also tried Firefox. And last, a completely different computer running Windows and Edge. All the exact same behavior. Can’t state enough how frustrating this is. The two servers are now two hours away and I can’t connect to them!

An inspect of the page seems to show a status code 400 error…
Screenshot_20221115_144547

Sorry for all the individual posts. There’s no edit option :frowning:

I followed this formal Docs how-to Connect with SSH through Cloudflare Tunnel - https://developers.cloudflare.com/cloudflare-one/connections/connect-apps/use_cases/ssh/ & Browser-rendered terminal https://developers.cloudflare.com/cloudflare-one/applications/non-http/#rendering-in-the-browser to set up my ssh tunnels. As I stated in my opening post, tunnels were working well. Then deployed to site and now no access, yet the tunnels show up on dashboard. Aside from what I outline below in an attempt to gain access and short of going back on site I’m not sure what else to do.

I found this post SSH & VNC browser rendering fails - https://community.cloudflare.com/t/ssh-vnc-browser-rendering-fails/304487/24 on this forum that seemed like the problem was related to short-lived certs as it was the Browser SSH method that I had configured. But after a re-reading of Connect with SSH through Cloudflare Tunnel https://developers.cloudflare.com/cloudflare-one/connections/connect-apps/use_cases/ssh/ it seemed clear it wasn’t as my understanding is that setting up the Browser SSH Rendering handled all the certificates. I decided to try and connect via cloudflared binary. On that same how-to docs page section # Connect to SSH server with cloudflared access https://developers.cloudflare.com/cloudflare-one/connections/connect-apps/use_cases/ssh/#connect-to-ssh-server-with-cloudflared-access. Following those steps I configured my client ~/.ssh/config file. Then on the first ssh connection attempt I got:

Please open the following URL and log in with your Cloudflare account:

https://<target_domain>/cdn-cgi/access/cli?edge_token_transfer=true&redirect_url=https%3A%2F%2F<target_domain>%3Ftoken%<blah blah blah%253D&send_org_token=true&token=%3D

Leave cloudflared running to download the token automatically.

The link loaded an Access Requested webpage. With a prompt to Deny or Approve. I Approved.
Screenshot_20221115_165646

Now all I get is this following a long pause waiting for the ssh session handshake to fail:

[email protected]:~$ ssh [email protected]<target_domain>
kex_exchange_identification: Connection closed by remote host
Connection closed by UNKNOWN port 65535

My ~/.ssh/config

[email protected]:~$ cat ~/.ssh/config 
Host ssh-<target_domain>
User <user>
ProxyCommand /usr/local/bin/cloudflared access ssh --hostname %h
IdentityFile ~/.ssh/cloudflared-tunnel

ssh -vvv

[email protected]:~$ ssh -vvv [email protected]<target_domain> 
OpenSSH_8.9p1 Ubuntu-3, OpenSSL 3.0.2 15 Mar 2022
debug1: Reading configuration data /home/user/.ssh/config
debug1: /home/user/.ssh/config line 1: Applying options for ssh-d<target_domain>
debug1: Reading configuration data /etc/ssh/ssh_config
debug1: /etc/ssh/ssh_config line 19: include /etc/ssh/ssh_config.d/*.conf matched no files
debug1: /etc/ssh/ssh_config line 21: Applying options for *
debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts' -> '/home/user/.ssh/known_hosts'
debug3: expanded UserKnownHostsFile '~/.ssh/known_hosts2' -> '/home/user/.ssh/known_hosts2'
debug1: Executing proxy command: exec /usr/local/bin/cloudflared access ssh --hostname ssh-d<target_domain>
debug1: identity file /home/user/.ssh/id_rsa type -1
debug1: identity file /home/user/.ssh/id_rsa-cert type -1
debug1: identity file /home/user/.ssh/id_ecdsa type -1
debug1: identity file /home/user/.ssh/id_ecdsa-cert type -1
debug1: identity file /home/user/.ssh/id_ecdsa_sk type -1
debug1: identity file /home/user/.ssh/id_ecdsa_sk-cert type -1
debug1: identity file /home/user/.ssh/id_ed25519 type 3
debug1: identity file /home/user/.ssh/id_ed25519-cert type -1
debug1: identity file /home/user/.ssh/id_ed25519_sk type -1
debug1: identity file /home/user/.ssh/id_ed25519_sk-cert type -1
debug1: identity file /home/user/.ssh/id_xmss type -1
debug1: identity file /home/user/.ssh/id_xmss-cert type -1
debug1: identity file /home/user/.ssh/id_dsa type -1
debug1: identity file /home/user/.ssh/id_dsa-cert type -1
debug1: Local version string SSH-2.0-OpenSSH_8.9p1 Ubuntu-3
kex_exchange_identification: Connection closed by remote host
Connection closed by UNKNOWN port 65535
[email protected]:~$