Argo Tunnel problem - Could not resolve host: uuid.cfargotunnel.com

My config.yaml

tunnel:  <UUID>
credentials-file: /root/.cloudflared/<UUID>.json

ingress:
  - hostname: omv.<DOMAIN>
    service: http://localhost:8080
  - hostname: portainer.<DOMAIN>
    service: http://localhost:9000
  - service: http_status:404

When I try to run tunnel I doesn’t get any errors

[email protected]:~/.cloudflared# cloudflared  tunnel run proxy
2021-11-18T15:50:17Z INF Starting tunnel tunnelID=<UUID>
2021-11-18T15:50:17Z INF Version 2021.11.0
2021-11-18T15:50:17Z INF GOOS: linux, GOVersion: devel +a84af465cb Mon Aug 9 10:31:00 2021 -0700, GoArch: amd64
2021-11-18T15:50:17Z INF Settings: map[cred-file:/root/.cloudflared/<UUID>.json credentials-file:/root/.cloudflared/<UUID>.json]
2021-11-18T15:50:17Z INF cloudflared will not automatically update if installed by a package manager.
2021-11-18T15:50:17Z INF Generated Connector ID: 0edc2aa4-e0e5-47f5-8a6e-7f1d2265bb56
2021-11-18T15:50:17Z INF Initial protocol http2
2021-11-18T15:50:17Z INF Starting metrics server on 127.0.0.1:41537/metrics
2021-11-18T15:50:18Z INF Connection 44e2d278-81a4-46ac-b9b2-4cbf5d6bde50 registered connIndex=0 location=VIE
2021-11-18T15:50:19Z INF Connection e48fe212-f82f-439e-bb40-102d31b33456 registered connIndex=1 location=PRG
2021-11-18T15:50:20Z INF Connection da48374e-8e1a-42d6-8c22-bf8b3b118ff8 registered connIndex=2 location=VIE
2021-11-18T15:50:21Z INF Connection 895ace56-ba6b-4c24-9e2b-b0bc40405b3a registered connIndex=3 location=PRG

And when I try to enter the site through my domain I get error 521 (Web server is down)


I connected my custom domain with the command cloudflared tunnel route dns omv.DOMAIN.

Additionally, I checked if the direct link to the UUID.cfargotunnel.com tunnel works.
However, he also threw me a error (DNS_PROBE_POSSIBLE or DNS_PROBE_FINISHED_NXDOMAIN)

I also tested quicktunnel - cloudflared --url http:// localhost:8080 and it gave me a random domain and it worked but with a custom domain it didn’t!

I think everything’s set up correctly from what I can see right now.

As of the time of writing, your tunnel is off (you haven’t got cloudflared tunnel running) so I couldn’t validate any further.

Can you get it running?

should already be on

Can you check either command line: cloudflared tunnel list (it should show tunnels connected to two datacenters each)
Or in the Teams dashboard:

[email protected]:~# cloudflared tunnel list
You can obtain more detailed information for each tunnel with `cloudflared tunnel info <name/uuid>`
ID                                   NAME     CREATED                       CONNECTIONS
UUID                              omv        2021-11-17T16:59:10Z
UUID                              proxy      2021-11-18T04:39:13Z    2xPRG, 2xVIE

Do I need an active free package with cloudflare teams to be able to use the tunnels? Because maybe this is a problem (I do not have any active package because I have not provided payment details)

Based on some internal troubleshooting, I think you may have Railgun enabled for those origins. I cannot confirm though (I’m not with the support team), but it’s my hunch.
Having Railgun for the same origin where you have Tunnel shouldn’t happen. So I’d say you should disable Railgun (see https://developers.cloudflare.com/railgun/user-guide/administration#enabling-railgun for where/how).

No. That is only needed for WARP → Tunnel routing (for building a “VPN” over Cloudflare).

3 Likes

it worked so much thanks
and besides the topic, if you can know, maybe you can have your own domain in access in the free version

I did not quite get the question.

But yes, Access/Teams has a free plan that entitles you to do everything (with the limitation of up to X users, I think 50).

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.