Argo Tunnel Not working with custom domain

My config.yml

tunnel: 12345678-1234-1234-1234-123456789101
credentials-file: /home/me/.cloudflared/12345678-1234-1234-1234-123456789101.json

ingress:
  - hostname: example.com
    service: http://localhost
  - hostname: test.example.com
    service: hello_world
  - service: http_status:404

when i run cloudflared tunnel run

2021-07-02T10:16:58Z INF Starting tunnel tunnelID=12345678-1234-1234-1234-123456789101
2021-07-02T10:16:58Z INF Version 2021.6.0
2021-07-02T10:16:58Z INF GOOS: linux, GOVersion: devel +11087322f8 Fri Nov 13 03:04:52 2020 +0100, GoArch: amd64
2021-07-02T10:35:37Z INF Settings: map[cred-file:/home/me/.cloudflared/12345678-1234-1234-1234-123456789101.json credentials-file:/home/me/.cloudflared/12345678-1234-1234-1234-123456789101.json logfile:/home/me/.cloudflared/cloudflared.log]
2021-07-02T10:16:58Z INF cloudflared will not automatically update when run from the shell. To enable auto-updates, run cloudflared as a service: https://developers.cloudflare.com/argo-tunnel/reference/service/
2021-07-02T10:16:58Z INF Generated Connector ID: 6c144842-5f5f-44b8-a8ff-584d2266cc52
2021-07-02T10:16:59Z INF Initial protocol http2
2021-07-02T10:16:59Z INF Starting metrics server on 127.0.0.1:44100/metrics
2021-07-02T10:16:59Z INF Starting Hello World server at 127.0.0.1:37139
2021-07-02T10:17:00Z INF Connection d0d04b19-de8a-441b-8fbf-d6a3f108e1ec registered connIndex=0 location=SIN
2021-07-02T10:17:01Z INF Connection db4089c1-13b3-4260-86a3-7145fce0df99 registered connIndex=1 location=HKG
2021-07-02T10:17:02Z INF Connection 4e9e2f49-3f78-47ba-95c3-2570d3580294 registered connIndex=2 location=SIN
2021-07-02T10:17:03Z INF Connection 8bc43784-6141-4a5b-8dc0-6c1d0038d8c6 registered connIndex=3 location=HKG

its showing like its working but if i visit my domain
Screenshot from 2021-07-02 16-39-00
i already added cname 12345678-1234-1234-1234-123456789101.cfargotunnel.com on my domain i tried with different port on config file i tried with different subdomain and i tried in fedora and debian with 2 different domains same issue…

help me please!
i am not using cloudflare access to use argo tunnel so don’t know if it needed or not!
and i tested just my running cloudflared tunnel --url http://localhost and it give me a random domain and it worked but with custom domain its not!

I don’t think that’s a Cloudflare Tunnel issue. It looks like a problem with your Universal SSL certificate.

1 Like

thanks a lottttttt 2days wasted , thanks a loooooooot :star_struck:

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.