Argo site without https - How?

I am trying to reach a site - published thru a tunnel - on http:// rather than https://

This is how I want to publish CTF challenge websites running on different ports on the same machine, doing the routing in config.yml. The publishing and routing works.

My main domain has a policy that redirects all to https, yet I still see http on the end-of-tunnel machine, maybe because the service redirect is set as http. Since traffic is encrypted in the Cloudflare Tunnel , this is fine. I can always switch to origin certifcate and https later.

Nw, how do I disable, for specific subdomains, any https rewrite on cloudflare ? I tried with a rule matching the hostname.
Disabled Automatic HTTPS Rewrites (optional)
Disabled Opportunistic Encryption
Set SSL (optional) to off

Yet I still get 301 redirects to https.

Any hints on how to avoid this ? I want to make it easy for the “students” to monitor traffic without Fiddler / Burp.

Make sure “Always use HTTPS” is also disabled. It can’t be disabled for subdomains, only the whole zone, so you’ll have to turn it off then set a rule for the apex and any subdomains to redirect to HTTPS for those you need it on.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.