Argo doesnt working

Hello guys,

I just enable Argo in the Cloudflare panel and I’m paying $5.00/m for Argo plan basis but always I access Argo panel it says the following:

Response Time (Origin → Cloudflare)

Argo Smart Routing is optimizing 0.0% of requests to your origin. There have not been enough requests to your origin in the last 48 hours to display detailed performance data.

Looks like it isnt working. There is any specific thing should I need to do to make it functional?

Thanks

Detailed performance data within Origin Performance (Argo) will only display if Argo has routed at least 500 origin requests within the last 48 hours.

Another thing you can check is if you turn on Tier Cache. If Tier Cached is enable and the routing is already optimized, Argo will be less likely applied.