Argo billing - can't find usage in billing

Hi, I can’t know how much I’m going to be charged it seems. I can’t find any argo billing usage in my dashboard. I’ve had argo enabled for 3 days.

1 Like

I’ve been using Argo for a few months and I don’t remember ever seeing this information on the Cloudflare Dashboard.

Perhaps this would be a good Product Request, just like the “Add Argo capped billing thresholds” suggested by @eva2000.

1 Like

There’s an article by cloudflare stating that they have argo billing usage in the billing portal, which would outline how much I’m getting charged, but there is no such page in the billing portal when I login. I believe there’s a bug.

You’re right.

I didn’t know the section Using billable usage to estimate Argo cost from Billing for Argo.

This image (from the support page) shows that this is a beta feature. This may be why it is not yet available for all users.

Anyway, it’s not available for me either.

So this means Cloudflare is going to charge me some unknown amount, without my knowing. Ugh. Guess I wont be using the feature since they are going to just charge me w/o my knowledge.

I found argo pricing:

“Enabling Argo in the Cloudflare dashboard initiates a USD $5.00 monthly charge. After transferring the first gigabyte of traffic between Cloudflare and your visitors, you are charged an additional USD $0.10 per gigabyte.”

The article still shows the same image and instructions, but the actual Billable Usage page still isn’t showing an “Argo traffic” section as described in the help doc. This was first reported more than two months ago; does anyone know what’s up?

@NP-Paul - Stay away from Argo. They charged me a surprise $700 for one month and did NOT want to refund it. There was no indication of usage. Do NOT use it.