Apps + Google Sites

Most apps I have tried work with my other sites, but when I try to add apps to a google sites page, most don’t work. Help please

Your now-deleted other post contained much more useful information.

Turns out most the stuff on the old post were fixed by going incognito (no idea how, maybe because of extensions) which means my only problem is apps not installing on google sites pages

I’ve never used apps on Google Sites pages. I’m not sure how that relates to Cloudflare, though.

Okay so i’ll break this down.

Under my domain, I have:

A google sites page (root)
A HTML page (subdomain)

When I add an app to all pages, I see it on the HTML page, but almost most of the time it never appears on the google sites page.

Ah, I see. You’re trying to use a Cloudflare App on your site, and your main site is hosted at Google Sites. But it only appears on the non-Google subdomain, and rarely on the main site.

Which app? I randomly selected a Twitter tweet to see how it adds to sites, and it looks like it only lets me select one hostname.

I tried many but for example I tried a back to top button.

Any other site on my domain that isn’t hosted by google sites :white_check_mark:
Google sites :x:

Does it show in the app Preview?

Have you opened your browser’s Dev Tools (F12 in Chrome) to look for errors in the Console or Network tab?

Shows in preview, not on website. Did find this in the console though. – The link shown in screenshot, includes cloudflare stuff

You’ve set a CSP that doesn’t include ‘self’ in script-src.

Just to make sure im going to try another app.

link from image -

no idea how i would fix

Once again, it’s your Content Security Policy.

How do I fix that

Turn off that CSP header. It’s rare for someone to have that unless they’ve deliberately set it. It’s most likely a setting at Google Sites, but there’s the very slight outside chance you added it via Cloudflare’s new Transform Rules for Response Headers.

I don’t see anything for CSP in google sites, where would I find it in cloudflare?

If you don’t see it in Transform Rules, and that’s a very slim chance at this point, you might have a Worker (right above Rules) that adds the header (slimmer-than-slim chance):

And for workers, I only have one for an app called edgy or something like that

Can you change that Worker’s route? I usually add some gibberish subdomain for the Worker Route to stop it from running on my site.

Well when I installed the app it said that Its gonna add a worker and I pressed continue but I cant see any workers inside of the workers tab

As I said, pretty slim chance. I’m pretty sure this comes from the origin. Especially considering it includes a nonce, which is usually set on the server. You’ll have to ask around at some Google Sites forums or Support where this is coming from.