Apps don't get served on non-standard ports

using_apps

#1

Hello,

I just noticed that cloudflare injects a javascript file into our pages:
https://PRODUCTION_DOMAIN/cdn-cgi/apps/head/gH_TNSlZvTnZNAf4E73mYHOr8kY.js?_=1500751824745

As the CloudFlare error page shows. This script is loaded from bundles.cloudflareapps.com.

This is fine for our production platform But on our prepord platform which is not listening on a regular http port, the javascript file can’t be loaded and the page crashes.

https://PRODUCTION_DOMAIN:8443/cdn-cgi/apps/head/gH_TNSlZvTnZNAf4E73mYHOr8kY.js?_=1500751824745

Here is a screenshot:

Thanks,


#2

Hi! Thanks for reporting. We’d love to chat more about the specifics of your site. Would you mind sending an email to [email protected]?


#3

Hello Zack,

Yes sure.

Best,


#4

Did you have any luck resolving this? I am having the exact same issue trying to access a Solr server running on port 8443


#5

Different issue I think @WishFarms. In your instance you’re using a port Cloudflare doesn’t support for proxying at all. Here’s a list of the ports we do support: https://support.cloudflare.com/hc/en-us/articles/200169156-Which-ports-will-Cloudflare-work-with-

Yu could either move solr to another port or set up a reverse proxy on your server to redirect from a port we do support to the one solr is listening on.


#6

I am having the same problem, I am running a development https Web server on port 8443 until a month ago everything worked fine, but now I getting

Failed to load resource: the server responded with a status of 522 () https://dev.[DEV_DOMAIN].ro:8443/cdn-cgi/apps/head/kCdqo0CznoQfgalTefeLmoYgiFE.js

The web page loads but very slow due to the timeout error. The problem only occurs with custom ports. (as I have another subdomain without a custom port, and https, and there is no error.)

Also if you disable all your apps for the address with the custom port the problem will not occur anymore, so until fixed I will disable my CloudFlare Apps.

Thanks in advance.