App Launcher does not update team subdomain


Yesterday I created my account and noticing some odd behaviour w.r.t. App Launcher. When trying out Zero Trust I did setup a temporarily team domain which I changed after all things where setup correctly.

However, the App Launcher screen keeps mentioning the old team domain where-as the domain shown in the address-bar of the browser is actually serving the page from the new team domain.

See screenshot which shows this mis-match. I tried different browsers / hard-refresh / modify the application to force a refresh but nothing helps.

Any help?

Try these different ways that could be helpful.

  • Clear the cache and cookies in your browser: Clearing the cache and cookies in your browser will sometimes alleviate caching issues that are causing the mismatched information to display. Clear the cache in the browser you’re using and then reload the App Launcher page.

  • Try incognito or private browsing mode: In your favourite browser, open a new incognito or private browsing window and proceed to the App Launcher. This option does not use your cached data and may assist in appropriately showing the latest information.

  • Log out and in again: Sign out of your account completely, close your browser, reopen it, and log back in. This will refresh your session and guarantee that you have access to the most recent information.

  • Contact support: If the problem persists after attempting the aforementioned procedures, it is advised to contact the App Launcher’s support staff or the service provider. They will be able to assist you further if they have access to particular troubleshooting steps.

Hi @alhseo ,

As you can see in my screenshot I’m using Incognito browser of Chrome. To rule things out I even installed a complete new instance of Firefox (portable) and there also the old name is shown. At this point I’m pretty certain it’s not client-side caching.

Also under my Website → domain I did purge the cache but that is imho not connected to App Launcher at all and also did not make any difference.

I managed to solve the issue. Apparently it’s under:

Zero Trust → Settings → Custom Pages → Login Page

There you have the “Your Organization’s name” which is shown on top of the subdomain. I had to change it manually to the new subdomain to make it consistent with the name change. Confusing but solved!