.app domain - SSL not working for some reason

ssl

#1

Hello, I’ve just purchased rkjsezana.app and I’m trying to setup SSL over CloudFlare’s network. I’ve got the .pom and .key files all set up on virtualhosts, but for some reason, when trying to connecting to the site I get an error message that “the site can not provide a secure connection” ( https://rkjsezana.app )

I do know that .app HAS to be accessed with HTTPS (this is also why I’m setting all this up, I’d do it lated if it was not for this).

Is there anyone that has a slight idea how to fix this?
Do you need any more info, if so please leave a reply, I will provide it as soon as possible :smiley:

Thank you for any info in advance,
Aljaž.


#2

That looks like your SSL here at Cloudflare has not finished setting up. On the Crypto settings page here, what’s the Status? It *should * be Active Certificate, but it could be something like “Still initializing”


#3

The certificate is marked as “active”, yes.
Also, forgot to mention; i’m using the strict option (everything is set up on the virtual server, using nginx)


#4

Open a Support Ticket. It could even be an issue with .app TLD being so new. But that’s an error with the certificate on Cloudflare.
support AT cloudflare DOT com
https://support.cloudflare.com/hc/en-us/requests


#5

I will :smile:

Thank you for helping.


#6

Alright, now (after a day) it works. I did not get the reply from CloudFlare’s support, but whatever. Maybe it just had to fully process the whole certificate thing, since the domain REQUIRES to fully support https protocol.


#7

Support for the free plan is usually slow, yeah…


#8

This topic was automatically closed after 14 days. New replies are no longer allowed.