APO Wordpress plugin not detected

Today I moved a website from one Cloudflare account to another. APO was working fine under the old account. Under the new account, I get a Wordpress plugin not detected error in the Automatic Platform Optimization for WordPress section of the Cloudflare admin. Under the new account, I have tried a new API key (using the Wordpress template) and I have tried the general API key and neither work. I have removed and reinstalled the plugin which allows me to provide the new email address / API key to the plugin. I have chosen the option to apply recommended changes via the plugin. I have switched APO on and off via the plugin, but it doesn’t change the value in the Cloudflare admin, and APO is not working. If I choose Purge Cache in the plugin, I get a forbidden message. I’m not sure what else to try at this point.

These are the only cf headers I’m seeing:

Hi there,

Weirdly enough, the plugin still shows active in your moved (old) zone.

I would advise you log into your dashboard → websites- > click the domain with the moved status → Speed → Optimization → Content Optimization → flick the APO switch to disable.
Now go back to your WP administration, uninstall the plugin and try reinstalling it again from scratch.

Take care.

1 Like

Hi and thanks for the reply. Just to wrap things up, flipping the APO switch to disable on the moved (old) zone didn’t correct the problem. Oddly, it would just change the setting in the plugin on the new zone and vice versa - so everything was definitely still tied to the moved site somehow. I ended up having to go to the main dashboard page and choose Remove Site from Cloudflare on the old zone. Once the old site was removed completely, I reinstalled the plugin with a new API key from the new zone and all is well.
Thanks again for the reply - it got me on the right track.


Hi there,

No problem! I’m glad to hear this is now resolved.

Take care.

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.