APO / Wordpress Configuration Problem

Hi, I am trying to enable APO for WordPress. I’ve searched through many answers in this forum, but couldn’t find anything the right answer. I’ve also tried filing a ticket directly with Cloudflare, but they keep ignoring me and pushing me over here.

So first, the diagnosis…

This is the website in question: https://www.tvinsider.com/

I am following the instructions here to verify that APO is working:

It says to look at three response headers. Here are my results for those:

cf-edge-cache | cache,platform=wordpress
This is good! It confirms the plugin is working.

cf-cache-status | Dynamic
This is bad? It says that I want “HIT”

cf-apo-via |
This is bad. I don’t get this header at all.

I’ve looking through dozens of support tickets to isolate what I might be doing wrong. Things to know:

  • As noted above, I am using Cloudflare Wordpress plugin. API key was added and everything suggests it’s working.

  • All of my DNS goes through Cloudflare.

  • I have Proxy domain turned on in Cloudflare.

  • I don’t have any custom Page Rules set up within Cloudflare. (It is my understanding you don’t want this when using APO.)

  • APO is turned on in the Cloudflare dashboard.

  • I have a “Pro” Cloudflare plan.

  • I don’t see any cookies that are trying to trigger a bypass.

  • The site is hosted by WP Engine. Their support team cannot find anything wrong.

Help?

I see this so far:

cache-control: max-age=600, must-revalidate --> Wonder where from does this come? APO, or origin?
cf-cache-status: DYNAMIC
cf-edge-cache: cache,platform=wordpress

However, at WPEngine do you also have some origin cache or some other caching plugin for WordPress alongside Cloudflare APO? :thinking:

x-cache: HIT: 15
x-cache-group: normal
x-cacheable: YES:600.000

Any other settings configured in the interface of the APO itself? :thinking:

Thanks for the response!

No, WP Engine does not allow any other caching plugins. The only cache is their built-in varnish. That is what is setting the max-age=600 cache-control. That is their basic setup for everything.

In wordpress, the only APO setting in the Cloudflare plugin is binary — ON or OFF. It’s of course set to ON.

Same goes in the Cloudflare console. APO is just something you toggle ON/OFF. It’s ON.

Documentation suggest you should be able to control cache settings in your account when using WP Engine, but this here suggests APO does not work with Advanced Network.

Thanks for the response!

I’m not using Advanced Network. I’m using their GES Network. Comparisons of types here:

WP Engine itself has directed me to use APO.

Wonder if there is a way to temporary disable it for testing purpose?
Could possibly disable it?
Therefore, purge the origin cache, purge the Cloudflare cache / APO and test out only with Cloudflare APO? :thinking:

Wonder if they interfere with each other, somehow.

I haven’t used Varnish a lot, so cannot tell much despite it’s known for a server-side caching.

I believe this has been solved. WP Engine had me change the CNAME record. I don’t completely understand why, but it was described to me as though we were attempting to “double cache” pages.

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.