APO showing an old version of my site

When enabling APO an old version of my site appears. I have purged cache from cloudflare but doesnt seems to fix the issue

With APO enabled there is this slider that I deleted long time ago


Also this slider that I have with the background changed

With APO disabled this fixes

I have disabled internal CACHE too but still

I left APO enabled

site is www.adams.com.ec

I see that it’s currently cached by APO and this is what it looks like:

I am glad the homepage updated,

Works for me too now

I am also experiencing issues with APO in the products pages

How it should look (APO Disabled),

How it looks with APO enabled

Product pages links



Are you using any other caching plugins in addition to APO?

Indeed, WPRocket

But I have tested with it disabled and cache cleared and still issue persist

It works correctly when I disable APO, and when enabling it again issue repeats

Give it another try. We just pushed some new changes this morning that might help with your issue.

1 Like

Thank you very much for the fast response.

I tried again, however I still see the issue.

I am sure the issue comes from APO.

I have tried everything , even moving from host but the only thing that “fixes” it is disabling APO.

I purged the cache in cloudflare, didnt do it when I tested a few minutes ago.

I think it is working now

I actually think this is probably because of the way your css versioning / caching is working.

I’m guessing when you turn APO on, it may just be grabbing the wrong css file that’s been cached.

What do you suggest there?

Right now it is working flawlessly, it may be the release pushed this morning

After purging cloudflare cache it worked fine

(Yesterday I purged it so many times with no success)

With APO enabled
What I was experiencing is the site trying to load old files that were not used anymore. There were even files that didn’t existed anymore.

My thought was that the site was trying to load an old version of the site, the weird thing is that it couldn’t not be my server doing that, it mostly probably was cloudflare doing that since enabling development mode did avoid the issue.

Do you mean it’s working WITH APO enabled this time?

We also released a plugin update this morning.

Hopefully these two changes fixed it for you! If not, I’d love to dig in and figure out why it’s still broken.

1 Like