APO for WP - Missing response header

The Cloudflare WP plugin displays:

cf-edge-cache response header is missing! Please clear any server cache used via other plugins.

We DO use WP Rocket ( Compatible plugins) and AMP Cache (not listed on Cloudflare plug-in compatibility page) but DO NOT use Imunify360 (Plugins and services that may cause issues).

I checked the page Ultimate Patio Umbrellas Buying Guide - Best Tips for 2021 and did see the cf-edge-cache header listed (although the value was “no-cache”).

I went into Troubleshooting for the Cloudflare WP plugin-in and was able to see the cf-edge-cache header (although the value was still “no-cache”). I then enabled both WP Rocket and AMP cache and reloaded the page. The result seems to be the same, so I don’t understand why Cloudflare is indicating that the response header is missing.

  1. cache-control:

no-cache, must-revalidate, max-age=0, max-age=0, no-cache

  1. cf-apo-via:

origin,cookie

  1. cf-cache-status:

BYPASS

  1. cf-edge-cache:

no-cache

  1. cf-ray:

650d552fff060d54-LAX

  1. cf-request-id:

0a1c3391fe00000d549d3be000000001

  1. content-encoding:

br

  1. content-type:

text/html; charset=UTF-8

  1. date:

Mon, 17 May 2021 13:53:35 GMT

  1. expect-ct:

max-age=604800, report-uri=“https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct

  1. expires:

Wed, 11 Jan 1984 05:00:00 GMT

  1. link:

https://decorinteriorsus.com/blog/wp-json/; rel=“https://api.w.org/”, https://decorinteriorsus.com/blog/wp-json/wp/v2/posts/4622; rel=“alternate”; type=“application/json”, https://decorinteriorsus.com/blog/?p=4622; rel=shortlink

  1. nel:

{“report_to”:“cf-nel”,“max_age”:604800}

  1. report-to:

{“endpoints”:[{“url”:“https://a.nel.cloudflare.com/report?s=JCGYL3iUh2L9LhknpcWmMzTfQxdd8S28b5OFDX1ODGLYvHVkahXLi6vUEPobTOd3U0g79OfcIHZ8ES7FVwUizeZFLq%2FDVLnH%2BFFt1RI3NELObfKeyYTz5PmoER5WaRbqyw%3D%3D"}],“group”:“cf-nel”,"max_age”:604800}

  1. server:

cloudflare

  1. set-cookie:

_nx-nocache=1; Max-Age=300; Path=/; HttpOnly

  1. vary:

Accept-Encoding

  1. x-mod-pagespeed:

1

  1. x-nocache:

1

It looks good to me:

Not sure where you’re seeing that, but I just purged the page cache on Cloudflare and then rechecked using Chrome (selected the second item on the left column).

The Cloudflare plugin also continues to show the error

Bill Ferris
773.383.9645 | [email protected]

Same thing in Firefox:

And Brave(Chromium)

Then I have no explanation why I cannot see it in Chrome. My concern is what enabling the Cache By Device Type will do, given that the Cloudflare WP plugin itself does not recognize it.

Bill Ferris
773.383.9645 | [email protected]

The only reason to enable Cache by Device Type would be if your site generates different content for different devices, like Mobile. Most new sites use responsive formatting, so the same cached content will work properly on all devices. But if you have a plugin or theme that creates mobile-only versions of pages, you’d want to enable that feature. You most likely should leave it “Off”.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.