APO does not update the Home page

Weeks later I still haven’t received any help from support for a service I have paid for: APO does not update the Home page when an entry is published.

If I activate APO, when I publish a post the Home is not updated unless I manually clear the cache. Any solution or do I have to downgrade the Cloudflare service I pay for?

Strange a bit about the homepage as far as I see cache-control: max-age=5, cf-cache-status: BYPASS and cf-apo-via: origin, no-cache HTTP headers so far.

1 Like

I followed the tutorial: activate the plugin, activate APO and test that it is active. It works, but when I publish a new post, the cache is not deleted until I go to the plugin and do it manually.

APO sometimes has problems determining which pages need to be purged, as it won’t do a Purge Everything and wipe out your entire cache.

If you open a ticket, (via email to support AT cloudflare DOT com), they might be able to determine why the plugin did not include your home page in the purge. If it’s like many of my sites, my home page is not the “Latest Posts” option, but a specific page with a Posts block.

When you get the autoreply for that ticket, please post the ticket number here so we can escalate it.


Hello, yes, I opened a ticket almost a month ago, but they only gave me generic answers: install the plugin, activate the plugin, delete and reinstall it… This is the ticket number: #2331399


I’ve added that ticket to the escalation queue. If a support engineer drops in this morning, as I heard yesterday that will happen, we’ll flag him down to get some eyes on this issue.

@user18410 I am currently looking into this ticket at the moment. Will update the ticket after my investigation.

1 Like

Same here, I have installed the Cloudflare plugin and homepage do not update after publishing posts, but when I move to wp-rocket it works.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.