APO disabling JavaScript

Hello, my website is https://heyloc.fr, once I enable APO, the javascript on the website and the Wordpress dashboard stop executing. I don’t have a caching plugin, I only use APO. The website is designed using Elementor if it can help.

I will disable APO for now, so the website will be working again. See the screenshots below.

With more testing, I confirm that the problem comes from APO. Even when I bypass the cache “Empty cache and Hard reload”, when APO is enabled it’s still breaking the website. I also think the " Automatic Signed Exchanges (SXGs)" option causes the same problem for me at least.