APO - CSS Problem

Good morning all,

For 1 week now, I have activated APO on my Wordpress site.

No real problem, see it works very well, but yesterday it was catastrophic.

All of the site’s pages were displayed in “mobile mode” on desktop browsers.

To solve the problem, it was necessary to refresh the page to have a correct display and to have an update of the page cache.

Have other people been impacted?

For information, the source server is under OpenLiteSpeed with the LsCache plugun.

Romain

Hi,
To follow up on my previous message. Is it possible to purge HTML cache on APO.
I suspect the Purge All is not working? CloudFlare has served me pages that have expired for 4 days.
Thank you

One thing that is obvious with APO, Cloudflare will serve whatever was first in cache, being it mobile or desktop version based on traffic.
I used to have two different templates for desktop and mobile, and I had this issue with the mobile version served on desktop and having to refresh the page to get the desktop version. Switching to responsive solved the problem.

1 Like

Thank you for your return,
Indeed, LsCache generates two different caches for me for Desktop and Mobile. I just reconfigured the plugin to generate only one cache. The site is already responsive.
Now there is the problem of purging the cache on CF servers so as not to send stale pages

Hi,
thats exactly the same behavior as described in this ticket:

Since yesterday evening, APO is not available, so i hope they work on a fix.

Regards,
Laszlo

1 Like

Hi @Romain-RDR-IT, “Purge All Cache” is the only way to update Cache in APO, it’s fully functional and we are not aware about any outstanding issues with purging.

Hello @yevgen,

From what I could see on my various tests that I carried out, I had the entire Wordpress cache cache regenerated on my site on October 10 and 11, I purged the CF cache on the board edge and last night I still had pages generated on October 3 and 4 to distribute by the CF cache.

I have a doubt about purging the cache …

Hi,
from friday night till yesterday evening my entire page was delivered in cf-dns-bypass mode directly via wordpress from host.
Yesterday, the cf-dashboard shows up no cache-fill events or else (cache was 0 byte in size).
Since a few minutes we can enable the APO from cf configuration (look here Enabling APO WP plugin: bad request)

I´ve tested this with my page and BAM.
Even when APO is enabled, the page was rendered in mobile mode with massive missing files (mostly css), so the page looks destroyed.

Problem still exists for me, diasble APO for my site.

Regards,
Laszlo

APO service is available,
I have just reactivated it and the first test I have just done, the CF cache gives me a page from October 02 (capture attached), except I have purged the cache since that date a good number of times …
I don’t know what to do anymore?


It’s a shame because the service looks really good but I’m wondering if I shouldn’t terminate it?
I had started to write a glowing article on APO because the first tests were really good, but now it’s a nightmare

I also suspect that CF is delivering old cached documents from somewhere. These documents are not covered by a purge cache and are also not displayed in the dashboards as content.

1 Like

To confirm your information, I also checked the data from my ticket again.
The page that is loaded when APO is switched on tries to download the following file:
autoptimize_4b728034d747c4548391e97315be9f54.css
In my test from October 9th, 2020 (saved in the webpage test https://www.webpagetest.org/result/201009_DiR6_d0baeaf87d21dd003b4e14a504de8d13/) it tried to load exactly the same CSS file. Which didn’t work back then either.
In between I did a purge cache at least 30 times.

I just did a test with another browser (FF), on the screenshot below, we can see the page that comes out of a cache on October 12th around 8pm. Since last night, to solve the problems I have purged the cache several times. So I should have had a page generated today …

I´ve inspected some of my logfiles.
In the error.log of my hosters apache there are the following entries:

[Tue Oct 13 15:02:06 2020] [notice] [Cloudflare] ERROR: [CLIENT API] Array\n(\n [type] => request\n [path] => https://api.cloudflare.com/client/v4/zones?action=cloudflare_proxy\n [timeout] => 30\n [method] => GET\n [headers] => Array\n (\n [Content-Type] => application/json\n [Authorization] => Bearer HERE IS MY API TOKEN!\n )\n\n)\n

[Tue Oct 13 15:02:06 2020] [notice] [Cloudflare] ERROR: [CLIENT API] Array\n(\n [type] => response\n [reason] => Forbidden\n [code] => 403\n)\n

[Tue Oct 13 15:02:06 2020] [notice] [Cloudflare] ERROR: Forbidden

Did this help for anything?

Regards,
Laszlo

1 Like

When will the cache purge problem be fixed?

I just did some random tests again, it’s a cataclysm

If you have enabled any Page-Rule, please give it a try and disable them.
Then purge CF- and Browser-Cache.
For me, this task solved the problems.

Regards,
Laszlo

thank you,
I’ll test and see if that changes fixes the problem.

Romain

This topic was automatically closed 5 days after the last reply. New replies are no longer allowed.