APO - Cloudflare cannot detect WordPress

I want to try APO in my WordPress website but cloudflare display the following message.

Note: This optimization is only available for websites using WordPress. We did not detect WordPress running for .

If I click Check Again, it shows error message with speed.api.feature_must_be_enbled (code: 10015).

Is anyone facing this?

3 Likes

I am also facing same issue.

1 Like

Same here :confused:

The plugin has been updated. This issue has been fixed. Please update the plugin and try again.

No, it still not working. Trying to chase you guys for the last 3 days but all are giving the same automated response. I have clearly mentioned that my website is in the root domain, I have a 3.8.3 plugin. I have purged my cache. Disabled wp-rocket but no success.

I can’t even apply basic settings via the plugin. When I checked the console it throws below log:

/wp-admin/admin-ajax.php?action=cloudflare_proxy:1
** Failed to load resource: the server responded with a status of 403 ()**

There is no firewall log to check what is blocking behind.

Please somebody here to support on this.

1 Like

Hey Tjain90,

me the same. No detectable WP-site. :joy:

But, where did you integrate the necessary API-Token? Can´t find a form in the plugin, where I can put the generated WP-Token? You?

When I installed plugin it asked for signin in Setting->Cloudflare
just enter email id and token for same.

I have been trying to solve this issue and the only thing I can think of is; does APO require XML-RPC? It’s disabled on my server for security reasons (which it commonly is).

Apologies you’re experiencing issues with APO detecting Wordpress. There are a few known reasons for this along with respective fixes:

  • WP plugin version before 3.8.2 is installed (we need 3.8.2 to detect plugin), remedy - install 3.8.2.
  • WP plugin version 3.8.2 is installed but existing caching plugins returned stale responses (without cf-edge-cache header), remedy- enable APO from WP plugin, purge caches in other plugins
  • WordPress only runs on a subdomain, we check for WordPress and WP plugin against the zone’s root domain. Remedy - liberate subdomain zone and run APO.

If you’ve tried all of these with no success, please let me know so I can collect some more information and forward it along to the team.

Thanks for your patience - we’ll get this resolved ASAP!

1 Like

Hi @aung_hein_mynn this error is fixed now.

3 Likes