APO: cf-edge-cache response header is missing

Hi, I’m getting this warning from within the wordpress cloudflare plugin dashboard. The site in question can be found at https://www.pars.work. I’m using the APO feature and it’s enabled on the Cloudflare side too. Worth noting is that I’m exposing my origin via cloudflared argo tunnel, routing traffic to a wordpress docker container.

Running a curl header command:
curl -s -I -X POST https://www.pars.work

Returns:
HTTP/2 200
date: Thu, 13 May 2021 02:13:04 GMT
content-type: text/html; charset=UTF-8
link: <https://www.pars.work/wp-json/>; rel="https://api.w.org/"
link: <https://www.pars.work/wp-json/wp/v2/pages/2124>; rel="alternate"; type="application/json"
link: <https://www.pars.work/>; rel=shortlink
vary: Accept-Encoding
x-powered-by: PHP/7.4.14
cf-cache-status: DYNAMIC
cf-request-id: 0a0518c55300001d874a13b000000001
expect-ct: max-age=604800, report-uri="https://report-uri.cloudflare.com/cdn-cgi/beacon/expect-ct"
report-to: {"endpoints":[{"url":"https:\/\/a.nel.cloudflare.com\/report?s=2thloteYT9Ke3zN9uZ4sLL00UKXZPMYSOGpUmYWTzTMgPsr5L23qri9Y7wkrvTjijEopV3PjcdxfoVtum%2FANQhk5HKppTGuZZgplv5ab"}],"group":"cf-nel","max_age":604800}
nel: {"report_to":"cf-nel","max_age":604800}
strict-transport-security: max-age=31536000; includeSubDomains; preload
x-content-type-options: nosniff
server: cloudflare
cf-ray: 64e85d821eb41d87-NRT
alt-svc: h3-27=":443"; ma=86400, h3-28=":443"; ma=86400, h3-29=":443"; ma=86400

That’s not the correct response, but when I visit it with a browser, I get the proper headers, including a Cache HIT. You also sent a POST request. I can’t imagine that APO would cache that. Again, I don’t know why your response netted a content-type of JSON.

Thank you for checking, that seem good news then! Does this mean that I can disregard the error message in the wordpress cloudflare plugin dashboard?

Even when fully clearing my browser cache and cookies for this domain, I’m seeing the following headers on the root document in the browsers’ Network section:

cf-apo-via: origin,no-cache
cf-cache-status: BYPASS

What am I missing?