APO - cant connect with WP site

Hi, i installed plugin Cloudflare - inserted API i created for wordpress, payed for APO, activated it and it is not working, when i check inspect - network - domain - header, there is missing confirmation : CF-Cache-Status: HIT

Instead i have this : Cf-Edge-Cache: no-cache

On TOP of this, i have not been able to reach any kind of cloudflare support, only this forum.

Can anyone help me please? Thanks

Please share you domain. Mark it as code </> or use the example[.]com notation.

lesia-nails[.]com

Hi, this is the site, im only getting

What you’re getting is a header added by the Cloudflare WordPress plugin. It adds this header regardless of your proxy status with Cloudflare. However, for APO and any other Cloudflare feature (other than DNS resolution) to work, you need to :orange: proxy any A, AAAA and CNAME records pointing to your hosting provider.

And before you can proxy your records, you need to point your NS records at your registrar to the Cloudflare assigned nameservers.

Reply from hosting provider:

As I see, this domain is using our nameservers.
I believe that in order for this to work, you would need to use Cloudflare.
From there proxy can be enabled/disabled.
While using our nameservers the DNS zone is here and there is no proxy option.

So should i change DNS records to cloudflare ones?

If you want to have your site proxied by Cloudflare, that’s the beginning of the process of adding it to Cloudflare.

At the same time, I wonder how did you pay for APO if your site isn’t even in Cloudflare yet. And what API key did you add to the Cloudflare plugin? Is this an offer from your hosting provider? If they are acting as Cloudflare partners and offering APO from their cPanel, you should contact them aboutt instructions on how to proceed.

  • I Payed via plugin - made a registration, added site and than in plugin clicked on purchase APO
    , already proxied to cloudflare, but im not still able to see apo in inspect/network/headers*

Official Cloudflare plugin for WP by cloudflare…

And i created API Key for WP

Sorry, I wasn’t aware that’s even possible to enable APO for WordPress, a feature that depends on Cloudflare cache, to a hostname not using Cloudflare nameservers.

So I guess now you need to add your website to your Cloudflare account. I you already did so, then you need to finish the setup and change nameservers as discussed before, from those pointing to your hosting, to the ones assigned to your account by Cloudflare.

Ok, resolved.

image

Thank you for you assistance :slight_smile:
Have a great day!

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.