APO cache issues

Hi,

I’ve been using APO for my WordPress site but I’m having a lot of problem managing it. The first issue is it always shows DYNAMIC cache status. To fix the same I added in page rule to cache everything but that setting is caching logged-in user pages as well.

What is the right way to use APO on WordPress?

Thanks!

You shouldn’t need to add a Cache Everything page rule. What’s the URL of a page that’s not working?

I’ve disabled cache everything. Please check this URL: Janaki Ammal: India’s First Woman PhD in Botany | AtomsTalk

That one is showing a HIT by APO:


This is what I’m seeing.

Request headers:

working on mozilla:

request headers on mozilla:

The issue on chrome maybe due to cache-control header but I tried disabling it on page rule: Origin Cache Control: Off

and still it didn’t work.

This usually happens if you’ve opened Dev Tools and toggled a Disable Cache option. You’ll notice in my screenshot I have it turned off.

OMG I am such an idiot :man_facepalming: :man_facepalming: :man_facepalming:

Surprisingly this gets retained in incognito as well.

Thanks a lot. We had been facing this for more than a month now :joy:

One quick question: APO doesn’t cache for logged in users, right?

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.

Correct. APO supports cache bypass based on wordPress cookies: https://developers.cloudflare.com/automatic-platform-optimization/reference/query-parameters#cookies-prefixes-that-always-bypass-cache