APO cache expiry date | cf-cache-status: MISS

Hi,

We’re using APO on the www.naturalmoreish.com.au

The problem is yesterday I saw cf-cache-status: HIT and we didn’t update anything on the home page but today I noticed that the cf-cache-status is MISS and after refreshing multiple times it’s HIT now. I think our cache expiry time has issues.

I have just checked other pages and it seems that I get cf-cache-status: MISS on all pages and after refreshing it changes to cf-cache-status: HIT. A few minutes later when I check that page again, the cf-cache-status header is MISS again :slight_smile:

Please check the below chart from Google Search Console:

17 Nov is the day that we enabled the APO :slight_smile:

I think it’s related to cf-cache-status: MISS.

*** For producing the issue, open an incognito tab and visit our website (naturalmoreish.com.au), you will see the cf-cache-status: MISS. After refreshing 1-2 times, you will see cf-cache-status: HIT.
Close this window and open another incognito window and open the website, you will see cf-cache-status: MISS.

Could you help me to increase our APO cache expiry time, please? I don’t want it to be 1 day or less.

Any solutions? we’re getting cf-cache-status: MISS on all pages :frowning:

Try clearing your page cache if you are using a plugin or server side and check again

1 Like

Thanks for the reply. I cleared all the CDN and server-side cache.

Do you know how to modify the APO cache lifetime?

Use a page rule to set the edge cache TTL

1 Like

Thanks!

I cleared all the caches (Kinsta server-side cache) and don’t using any cache plugins but I got cf-cache-status: MISS again :frowning:

That’s not the canonical URL of your site. It redirects to the URL without www. www showed a MISS, but when I next tried without www, I got a HIT on the first try.

1 Like

Thanks for your answer.

I’ve never tried with www. The problem is After some refreshes I got cf-cache-status: EXPIRED or MISS. That’w weird because our server cache TTL is 7 days. I enabled page rule with edge cache TTL for 3 days but I still get MISS or EXPIRED.

Can you tell me what is our website APO TTL, please? I can see different numbers there! There isn’t anything related to 3 days (259,200) which I set on Edge Cache TTL with page roles.

And please check my original question, you can see we get mobile errors since we’re using APO. Sometimes I get “Reduce Server Response Time” from Google Insights.

I think something is wrong with our server caching (Kinsta) or headers, I don’t know. We don’t user any additional caching plugins.

I am also getting hit on first try for https://naturalmoreish.com.au/

Also visit this page, might help
https://developers.cloudflare.com/automatic-platform-optimization/troubleshooting/faq

1 Like

Thanks for the effort. I understand the cf-cache-status is HIT for a lot of times, the problem is sometimes I get “Reduce Server Response Time” from Google Insights and as you can see in the first post, the Google Search Console shows error since I enabled the APO.

Maybe I should give it a time, I don’t know…

Thanks!

From GT Matrix and google page speed insight i see a lot of things to be improved like woocommerce cart fragments, images are jpeg, browser TTL and so on

1 Like

I see, I’m working on the TTFB and LCP for now, just installed ShortPixel Adaptive plugin today to optimize the images. But it seems we have a lot of issues …

How are you doing page refreshes via CTRL+F5 or normal F5? You have must-revalidate header for cache-control and on CTRL+F5 it will force a revalidation.

Also CF Wordpress APO doesn’t cache on no-cache requests and if you open web browser dev tool’s network tab make sure you do not have ‘disable cache’ checked as that forces a no-cache request to bypass Wordpress APO caching.

image